Remote admin panel access through Wireguard (client mode)


I want to access the admin panel of the router remotely through a WG connection ( from the WG server side) . I setup the router as a WG client and the tunnel works fine my home clients behind the router pass through the tunnel.

However I cannot at all ping the Wireguard IP address of the router, nor ssh to it. I guess it must be related to the firewall but I don’t understand how GLiNet firmware handles wireguard. I see a wireguard zone but no wireguard interface.

Any idea how can I access the router admin interface through WG from the server side ?

I am using the latest firmware.

This is usually because there is no “NAT loopback” a.k.a. “hairpinning”. Try Google for those terms for workarounds.

I do not work for and I am not directly associated with GL.iNet

In the wireguard connection, there should be an option “allow local access”. When you select you should be able to access the router using the wireguard IP.

I remember I tried already this and I could not, but I will try again to make sure.

Thanks for the tip, I will do my research.

Just use zerotier installvit on your router and phones and pc all connected 24/7 no need for a vpn its like having a virtual eathernet cord plugged into your phone no matter where you go even does udp hole punching.