Remote VPN through LTE connection (TMobile)

I have used GLiNet routers to gain access from my desktop to my work test lab using a static IP from the local cable company and have had reliable success.

I assumed that I could do the same using and X750 and a E750.
I bought LTE service data plans for both and tried to remote to the Network at the internal side of these networks.
I have not had success with either device being able to VPN into the device to control it.

From the LTE side (on both routers) they pull in an IP address from TMobile but the IP address is different in the VPN config file.

I tried using the DDNS name in the config file but when I try it never reaches either one.
Is TMobile blocking this??
Not too sure what else to try as setting these up is a fairly easy process.

If you use LTE, your carrier may not give you a public IP. So you cannot use as vpn server.

But you can consider our S2S solution. GoodCloud S2S - GL.iNet

You do not need to use X750 or E750 as the server. On the contrary, they are client and you use the router at your home as server. But you can access from each end.

Tried to do this but when I logged into GoodCloud it lost all of my connections. I guess now I have to manually rebuild them. How reliable will this be…?

What do you mean by “lost all of my connections”?

I had 2 routers connected in the cloud and under a group. When I logged in the next day the group and the routers were gone…
When I logged into the “missing routers” they said they still belonged to my username but alas they are not there.

What firmware are you using?

Pls also check if you changed the server location to other places.

For example if you change server location to US, but you check cloud and view EU, Asia region, you will not find the device.

That was it. My region defaults to other than US. And that is where it was hidden.
I setup the site to site but the last step to complete is to be able to vpn 10.x.x.x
To the home base router 192.168.168.x and access remote networks 192.168.10.x. I cannot ping or Tracert across it. Is there a firewall rule that I need to put in place?

I am able to access data across the farthest network (.167.x) from a VPN into .168.x.
I had to go into: More Settings > Advanced
Network > Firewall
Change setting Forward from reject to accept
viola!!!
These are the dopest devices ever…

1 Like