Removal of a SFT1200 from a lost GoodCloud Account

Morning all

Could anyone help with the removal of a GL-SFT1200 from an old GoodCloud account please?

I bought the device about 2 months ago, created a goodcloud account and added my device to it, all worked well.

Yesterday I tried to log back into to my goodcloud account and I couldn't get in due to authentication failures. I tried resetting the password but every attempt to do this would say "user does not exist" I tried a few other email addresses that I might have used during the initial signup but they all cannot be found when trying to reset my logon credentials.

So I created a new goodcloud account, but now when trying to add my device to goodcloud using the device ID/serial etc I get an error saying "device added by others"
Obviously this is my old account that I can no longer access, so how do I get it removed from the old account so I can add it to my new one?

Thank you

Hey :wave:

I had the same issue a few days ago.
After I disabled GoodCloud on the router, renabled it and re-register the device, there was a link saying something like "Unlink device" - does this exist in your dashboard as well?

I tried that yesterday but didn't seem to work... I'll give it another try though. When you say dashboard do you mean the admin page of the router?

I mean the admin page where you enable/disable GoodCloud.

No luck I'm afraid. Enabling and re-enabling GoodCloud doesn't change anything and I don't get any links saying to unlink the device.

According to the guide here GoodCloud - GL.iNet Router Docs 4 there should be an unbind link, but it's missing on my admin page.

I'm already on the latest firmware, would a factory reset help?


Are you on 4.3.11 firmware?


Yes 4.3.11 of the firmware

Well, time for the big master to have a look. :smile:

tldr: Device can't be unbound from GoodCloud, old GoodCloud account is lost - what now?
Unbound link is missing.

1 Like

I did a factory reset and that made no difference. This is the screen shot from within the admin panel showing the router is ready to be bound to a good cloud account. But when I try to actually add the device it says "device added by others" So I seems to be stuck in a catch 22 situation where the device thinks it's unbound, but goodcloud thinks it is bound.

Here's the screenshots. Hope they help...
Thank you

Can you send an email to support at

Pls send bottom label and your old account email if you remember


I've had an email from @alzhao and this issue is now resolved.

Thank you all for the help

1 Like