Repeater mode problem on GL-MT300N-v2

Hi all,

I have a problem when I try to connect my Mango to my local WiFi (Free provider).
I can scan my network, see it but after typing the password and clicking on Join, nothing happens.
The Join turn to grey, then green but the connection is not done. No message is displayed.

I really don’t know what happen.

I can use the repeater with LAN cable and with my wifi shared phone network.
The installed version is 3.211

Thanks for your help.
Joël.

Do you have any idea of what type of network they provide? Is it only one password or there is one username as well. Do they have any limitations?

You can also connect to the wifi on your pc and then post the details of the network which can be found in your pc so that we can investigate.

Thanks for your answer.

My answers: this is a common wifi/internet provided by a very common french provider (Free and the Freebox) with WPA key. No problem to connect other equipment to this network.

I can do that but what information do you need exactly from my network ?
So far, I saw that:
Protocole: Wi-Fi 4 (802.11n)
Security type: Personal WPA
Band: 2.4 GHz

Thanks.
Joël.

Can you post the portions of the System Log and Kernel Log, just before and just after the connection attempt?

That is really nothing special. Do you have the channel info?

Also give the log as @wcs2228 said

This is channel 1. For the logs, you spoke Mango logs, did’t you ?
How can I give you logs infos with this system ?

So far, I’m connected in ssh on the Mango and I have this continuous error (every about 2 sec) in dmesg:
ApCliValidateRSNIE - Validate RSIE Failure
[ 1162.582100] ERROR: The RSN IE of this received Probe-resp is dis-match !!!

I see nothing in /tmp/wifi.log
But in /tmp/log/lighttpd/error.log, I see this message just at the end of the ‘Join’ process.
2022-01-14 09:25:10: (mod_cgi.c.1031) CGI pid 32522 died with signal 5

Thank you for your time.

Hello, I have new information. In doubt, I have changed my wifi password that was containing so many strange caracters. I set it with no weird things.

Now, when I try to Join, I have this message in the /var/log/lighttpd/error.log just after the Join process:
client_loop: send disconnect: Connection reset by peer

Have you any idea, please ?

You should get the log using command “logread”, not from the lighttpd log, which does not provide necessary info for repeater connection.

Ok cool, I’m going to do that. Thank you.

And here are my logs:
— before Join —
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.557266] load fw image from fw_header_image
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.561775] AndesMTLoadFwMethod1(2548)::pChipCap->fw_len(63536)
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.567789] FW Version:
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.567793] _
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.570270] e
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.571862] 2
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.573468] _
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.575063] m
Fri Jan 14 10:15:20 2022 kern.warn kernel: [ 47.576657] p
Fri Jan 14 10:15:20 2022 daemon.info dnsmasq[1246]: exiting on receipt of SIGTERM
Fri Jan 14 10:15:21 2022 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Fri Jan 14 10:15:21 2022 user.info : gl_health start->
Fri Jan 14 10:15:23 2022 daemon.notice procd: /etc/rc.d/S99lighttpd: sed: /etc/lighttpd/conf.d/10-port.conf: No such file or directory
Fri Jan 14 10:15:23 2022 daemon.notice procd: /etc/rc.d/S99lighttpd: netstat: showing only processes with your user ID
Fri Jan 14 10:15:26 2022 daemon.notice procd: /etc/rc.d/S99wireguard: uci: Entry not found
Fri Jan 14 10:15:27 2022 user.notice wireguard: wireguard client start
Fri Jan 14 10:15:27 2022 daemon.notice procd: /etc/rc.d/S99wireguard_server: uci: Entry not found
Fri Jan 14 10:15:27 2022 daemon.info procd: - init complete -
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: started, version 2.80 cachesize 150
Fri Jan 14 10:15:29 2022 daemon.notice netifd: wan (1861): udhcpc: sending discover
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: DNS service limited to local subnets
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth nettlehash DNSSEC no-ID loop-detect inotify dumpfile
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq-dhcp[2231]: DHCP, IP range 192.168.8.100 – 192.168.8.249, lease time 12h
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain test
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain onion
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain localhost
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain local
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain invalid
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain bind
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: using local addresses only for domain lan
Fri Jan 14 10:15:29 2022 daemon.warn dnsmasq[2231]: no servers found in /tmp/resolv.conf.auto, will retry
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: read /etc/hosts - 4 addresses
Fri Jan 14 10:15:29 2022 daemon.info dnsmasq[2231]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Fri Jan 14 10:15:30 2022 daemon.info dnsmasq-dhcp[2231]: read /etc/ethers - 0 addresses
Fri Jan 14 10:15:41 2022 user.info mwan3rtmon[2174]: Detect rtchange event.
Fri Jan 14 10:15:42 2022 daemon.notice netifd: Network device ‘ra0’ link is up
Fri Jan 14 10:15:43 2022 daemon.notice procd: /etc/init.d/network: Interface doesn’t accept private ioctl…
Fri Jan 14 10:15:43 2022 daemon.notice procd: /etc/init.d/network: set (8BE2): Invalid argument
Fri Jan 14 10:15:43 2022 daemon.notice procd: /etc/init.d/network: mt7628(mt7628): enable failed
Fri Jan 14 10:15:48 2022 daemon.info dnsmasq-dhcp[2231]: DHCPDISCOVER(br-lan) 4c:1d:96:ad:2e:8d
Fri Jan 14 10:15:48 2022 daemon.info dnsmasq-dhcp[2231]: DHCPOFFER(br-lan) 192.168.8.211 4c:1d:96:ad:2e:8d
Fri Jan 14 10:15:48 2022 daemon.info dnsmasq-dhcp[2231]: DHCPREQUEST(br-lan) 192.168.8.211 4c:1d:96:ad:2e:8d
Fri Jan 14 10:15:48 2022 daemon.warn dnsmasq-dhcp[2231]: Ignoring domain pyro.groupe.local for DHCP host name E3541D03
Fri Jan 14 10:15:48 2022 daemon.info dnsmasq-dhcp[2231]: DHCPACK(br-lan) 192.168.8.211 4c:1d:96:ad:2e:8d E3541D03
Fri Jan 14 10:16:58 2022 authpriv.info dropbear[4479]: Child connection from 192.168.8.211:7628
Fri Jan 14 10:17:02 2022 authpriv.notice dropbear[4479]: Password auth succeeded for ‘root’ from 192.168.8.211:7628

— After Join —
Fri Jan 14 10:44:41 2022 authpriv.info dropbear[328]: Child connection from 192.168.8.157:1147
Fri Jan 14 10:44:48 2022 authpriv.notice dropbear[328]: Password auth succeeded for ‘root’ from 192.168.8.157:1147
Fri Jan 14 10:45:07 2022 user.info : gl_health start->
Fri Jan 14 10:46:08 2022 user.info : saved ssid ignore: DLF_Power 0
Fri Jan 14 10:46:08 2022 user.info : [ 810] gl-sdk>> bIsSaved=0, ssid=DLF_Power, encryption=psk, bssid=3A:86:AE:8C:C5:D0, wds=0, device=mt7628, identity=, channel=1
Fri Jan 14 10:46:09 2022 user.info : [ 2749] gl-wifi-core>> bIsStaEnabled=1
Fri Jan 14 10:46:34 2022 user.info : [ 817] gl-sdk>> wifi_join return=-5, channel=1
Fri Jan 14 10:46:34 2022 user.info : [ 1754] gl-wifi-core>> Restart wifi…
Fri Jan 14 10:46:35 2022 daemon.notice netifd: Network device ‘ra0’ link is down
Fri Jan 14 10:46:42 2022 daemon.notice netifd: Network device ‘ra0’ link is up
Fri Jan 14 10:46:43 2022 daemon.notice netifd: Network device ‘ra0’ link is down
Fri Jan 14 10:46:49 2022 daemon.notice netifd: Network device ‘ra0’ link is up

Hope that is enough for you. If you want more, please tell me.
Thanks a lot.
Joël.

Please show more log.

Wait some time and execute the command ‘logread’.

Hello,

Here is the link for the complete before.logs and after.logs files: Free Transfert - Service d'envoi de fichiers

For information, I have tested with some different WiFi configuration: WPA (TKIP+AES), WPA (TKIP) and WPA (AES/CCMP) but this is always the same result: no connection.

Thank you for your time.
Joël.

Hello All,

Sorry to insist but I gave you all my logs few days ago. Has anybody a good idea to resolve my problem ?
Is the link correct for downloading my logs ?

Thanks a lot.
Joël.

Please show the WiFi config:
cat /etc/config/wireless

Thanks Jerry. Here is the content of my /etc/config/wireless:

config wifi-device ‘mt7628’
option type ‘mt7628’
option htmode ‘HT40’
option ht_txstream ‘2’
option ht_rxstream ‘2’
option hwmode ‘11g’
option noscan ‘0’
option txpower ‘20’
option txpower_max ‘20’
option country ‘US’
option region ‘0’
option band ‘2G’
option mimops ‘3’
option wmm ‘1’
option channel ‘1’

config wifi-iface
option device ‘mt7628’
option network ‘lan’
option mode ‘ap’
option encryption ‘psk2’
option ssid ‘GL-MT300N-V2-401’
option wds ‘1’
option disassoc_low_ack ‘0’
option ifname ‘ra0’
option key ‘Animal12’

config wifi-iface ‘guest2g’
option device ‘mt7628’
option network ‘guest’
option mode ‘ap’
option wds ‘1’
option ssid ‘GL-MT300N-V2-401-Guest’
option encryption ‘psk2’
option key ‘goodlife’
option ifname ‘ra1’
option disabled ‘1’
option guest ‘1’
option disassoc_low_ack ‘0’

config wifi-iface ‘sta’
option device ‘mt7628’
option network ‘wwan’
option mode ‘sta’
option ifname ‘apcli0’
option ssid ‘DLF_Power’
option channel ‘1’
option encryption ‘psk’
option key ‘THE KEY OF MY NETWORK’
option disabled ‘1’

Is there a problem with one of these parameters ?
Why is this last network “disabled” ?

Thank you again.
Joël.

Hey, after studying parameters, I see something strange:
option channel ‘1’

So I tried with option channel ‘auto’, removed the disabled option, rebooted my Mango and … taaadaaa, it was connected to my network.

Not sure it is the “real” process but it works.

Thank you to all of you. Have a nice day.
Joël.

2 Likes

Thats cool you worked it out on your own. Sucks for community lack of participation. I have been out for awhile and looked up your issue as I have an MT300Nv2 ‘Mango’ I had issue with it being unable to associate with community mesh AP. Since then I made 2 major changes in my network… 1) I got my own residential service restored by ISP
2) I purchased a GbE PoE/vlan unmanaged workgroup switch .
That switch was such an awesome addition. I use it solely in vlan mode which segments my network and allows downstream coexistence of an AR750 and MT300Nv2 on seperate vlan ‘trunks’ … the switch does this by attaching a unique tag ala RFC for 802.13?
The switch also has an SFP port that I bought a second workgroup switch with SFP port and 2m patch cable … effectively extending the original switch…
I could share brand but I wont. It doesnt matter. What does is having an ability to transparently tag your traffic such that you can have segmentation without subnetting or additional agents in the mix… get a VLAN switch.