Root password not working for AR-750S

Hello,

I have an AR-750S that just arrived yesterday. I ran through the initial setup to set the Admin password. However, when I use the same password for root under advanced settings, the password doesn’t work.

I’ve factory reset the device several times by holding the reset button for at least 10 seconds. Each time it takes me through setup again where I enter the Admin password, but each time the root password doesn’t work. I also downloaded the openwrt-ar750s-3.009.img file from the GL.iNet website to try and reapply the image using the “bricked device” uboot method. Again, the admin password works but the root password does not.

Running firmware version 3.0009. It seems like the reset is not performing a complete reset.

Are there any other suggestions on what I can try? Please advise.

Does the password contains special characters? Such as dollar($) character. It is a bug in old firmware.

Yes, it does.

I have another AR750S with the same password, and it seems to work with the root password. The only difference is that the other one was purchased awhile ago (pre-3.009). I configured that one and then upgraded to 3.009. However, on this problem one it came with 3.009 already installed.

That sounds like a good point, perhaps I’ll try to flash an older firmware, confirm the password works for both admin and root and then re-upgrade.

Have you tried logging in with password “goodlife” (under Luci)?
If that works, go to system>administration and change it to what you want.

That did the trick. I flashed version 3.007 on the device using UBoot. After reboot on version 3.007, I went through setup again. This time the complex password i used worked for both admin and root. Next, I upgraded to 3.009. After reboot, the password works for root and admin as expected on 3.009.

This issue is resolved now. Thanks for the assistance.

yes, i tried goodlife and it didn’t work.

To get it to work as expected, I had to flash a previous version of firmware, set the password and then re-upgrade.

Password works for both root and admin now.

You can try the latest testing firmware. http://download.gl-inet.com/firmware/ar750s/snapshots/

If you want to use the stable firmware, you can back to 3.007, and wait for the next release.

I’m working on 3.009 right now and everything is working as expected. I haven’t looked at the snapshot firmware yet.