Router Drops All 2.4GHZ Connections At 28 Minutes Past Every Hour

I have a GL-S1300 as my main router and two GL-B1300 connected via the mesh network. After updating the software to version 3.105 I started noticing some of my devices started losing their connections throughout the day. After monitoring it for a few days I noticed it was the devices on the 2.4GHZ and it was occurring at 28 minutes past every hour.

I have a WiFi connected weather station that sends data to an LCD screen on my desk. When the weather station doesn’t have a WiFi connection an icon on the screen starts blinking. At 28 minutes past every hour I now notice all of the devices using 2.4GHZ lose their connection and the WiFi icon starts blinking. All of the devices on the 2.4GHZ connection so it’s not a problem with just that device.

If you give me instructions on how I can get you any diagnostic information or log files I’ll post that here.

After updating the software to version 3.105 I also notices the mesh devices started showing ‘no data’, not sure if thats got something to do with the problem or not.


It won’t let me attach a txt file and the output is too big to paste here, is a pastebin link OK?

If its related on weather radar around you, think about to do the follow:

  • configure on advanced admin interface your right country. Its set to us on on non configured default. A in some country’s like, eu, jp and other, you can use 3 or 4 more channels.
  • don’t select one static channel setting. Set the channel to automatic. They are some different opinions about what are good or bad channel around the world and they are some vendors around the worlds, which don’t force to config what need by first config. So set it to auto mode and let the router look by self what are actual available and have the lowest trouble. That can reduce your blood pressure…
  • disable on advanced admin menu 802.11b, if you don’t need for really old devices


It’s just easiest to verify the wifi is down on the weather device because of the blinking icon on the LCD screen. The drop-off occurs on my laptop and phone at 28 minutes past the hour, I can verify it by looking at the icon on the weather LCD screen.

I have to select a static channel I have 8 different Sonos units that use a mesh network and I have to make sure the channels don’t conflict or else there are audio dropouts.

The dropouts at 28 minutes past the hour only started happening when I updated the router firmware.

I can’t disable 802.11b I have multiple devices that only have that band.

All of these devices were working as expected before the router firmware update.

Here is the syslog

Here is the kernellog

Seems it is dhcp renew caused wifi restart.

Can you try snapshot? GL.iNet download center

This should have been fixed.

That completely broke the WiFi so that nothing worked.

I had to do a factory reset to get it working again, it took me 2 hours get everything working again. I am now back to version 3.104.

It sounds like you’re trying to keep settings when doing the upgrade? If you are i would suggest first use luci to backup the current configuration that works for you. Then factory reset. Install the update. Try to configure it from fresh to see if it works, if not reinstall 3.104 and restore the settings you backed up

I have a massive amount of internal rules I don’t want to lose. For example I’m blocking the hostname and IPs of over 100 DNS servers to prevent devices from trying to get around my PiHole. I also have a lot of rules blocking IoT devices from connecting and sharing information with third parties I don’t want them to connect to.

Losing all the settings and having to re-enter all of that information again would take me weeks to do.

With an upgrade like this you would have to. Going from openwrt 18.x to openwrt 19.x the config files will change for basic functions. Trying to keep all the configs will cause failure. Can you try to selectively backup the rules you need to save and restore only then after the upgrade?

So this “upgrade” arbitrarily breaks settings the customer has made, showing complete disregard for the amount of time the customers invested in setting up those rules…

An upgrade is supposed to make things better, not break things that were working and completely waste hours of peoples time.

It isn’t gl’s fault, they only put a skin and some scripting (it’s more than that, but that’s the basics) on top of ooenwrt. Openwrt has upgraded, providing improvements in stability, security, and functionality. The choice is yours, deal with the problems you have, or update and fix them. Which is worse, redoing your old lists, etc, or losing your connection every hour?


Since the “update” bricked my router I had to do a factory reset, and chose to restore an older version that worked, which seems to have removed the hourly dropouts.

So I fixed all my problems by not having the “update”.

I have blocked the subdomain for updates, so no one “helps me” by carelessly breaking my router in the future.

There’s a lesson in there somewhere if you try and find it…

Update is supposed to work with settings kept.

But not sure if you have too many rules