Router mode not bridging internet

My GL.iNet Opal is successfully connecting to the WiFi and I can ping internet IPs via Luci.

But when I connect a device to the WiFi my Opal is broadcasting, e.g. my laptop, then my laptop doesn’t have any internet connectivity, it can only access the local network provided by the Opal.

The two networks aren’t bridging/relaying properly?

I’ve tried resetting the Opal, using only built in configs and also by using openwrt/luci, I can’t get it to bridge the wifi it connects to and the network it broadcasts. The Opal is happily connected to e.g. my hotel wifi and can reach the internet fine. There are no indications on GL.iNet UI that there is anything wrong

  • You don’t happen to have a network cable to test Laptop → Opal LAN, I take it? You might be able to pick one up at a local dollar store.
  • Are you using a VPN &/or is the Kill Switch/Global Proxy enabled?

Please check the firmware of your Opal router. You can have a firmware update to make sure the version is latest. You can download the latest firmware on the website below:
You can try again after the firmware update.