Router Upgrade GL-X3000

When I do this upgrade it completes with success! Well its short lived when i get a continous reboot after. I get about 10 pings before it reboots. Any ideas? I tried different manual upgrades and same result with success and continuous reboot.

Do you change the mode of the module?

Versions above 4.3.0 detect whether the module is in pcie mode
Therefore, you need to upgrade the firmware to 4.3.0 first
Execute the following AT instructions


Restart the device
Enter router background

ssh root@
ls /dev/mhi   Press tab

See if these are generated

not sure what router background is?

Entered both AT commands and did a restart of router

root@GL-X3000:~# ls /dev/mhi
ls: /dev/mhi: No such file or directory

Looks like I do have them when I list the dev
root@GL-X3000:~# cd
root@GL-X3000:~# cd /dev
root@GL-X3000:/dev# ls
bsg mapper mtd1 ttyS15
bus mem mtd1ro ttyS2
conninfra_dev mhi_BHI mtdblock0 ttyS3
console mhi_DIAG mtdblock1 ttyS4
cpu_dma_latency mhi_DUN net ttyS5
full mhi_LOOPBACK null ttyS6
fuse mhi_QMI0 port ttyS7
gpiochip0 mmcblk0 ppp ttyS8
hwrng mmcblk0boot0 ptmx ttyS9
iio:device0 mmcblk0boot1 pts ttyUSB0
kmsg mmcblk0p1 random ttyUSB1
log mmcblk0p2 sda ttyUSB2
loop-control mmcblk0p3 shm ttyUSB3
loop0 mmcblk0p4 tty ubi_ctrl
loop1 mmcblk0p5 ttyS0 urandom
loop2 mmcblk0p6 ttyS1 vhci
loop3 mmcblk0p7 ttyS10 watchdog
loop4 mmcblk0p8 ttyS11 watchdog0
loop5 mmcblk0rpmb ttyS12 zero
loop6 mtd0 ttyS13
loop7 mtd0ro ttyS14

root@GL-X3000:/dev# ls /dev/mhi_DIAG
root@GL-X3000:/dev# ls /dev/mhi_DUN
root@GL-X3000:/dev# ls /dev/mhi_LOOPBACK
root@GL-X3000:/dev# ls /dev/mhi_QMI0

Now upgrade 4.4.8 will also restart?

1 Like

Completed update and is now running new load correctly.

Thank you