Routing to outer LAN with VPN active

This is for a GL-AR750S.

My network configuration is as follows: Cable Modem → Netgear (“outer”) router → GL (“inner”) router. The inner router is connected to a VPN.

I want the computers connected to the inner router (10.0.0.x) to be able to access computers and services connected to the outer router (192.168.1.x). I’ve tried adding routes using LuCI but they don’t seem to be working – see screencap.

The inner router has an address of on the outer network and I can ping that IP just fine from machines connected to the inner network (and they can, of course, freely talk to each other). I don’t know why the routes I’ve set up aren’t working – can anyone give advice, or provide next steps for troubleshooting?

Have you open the FORWARD from LAN to WAN in firewall settings?

Yes, LAN to both WAN and OVPN has FORWARD set to “accept.”

Should not the static route has as a gateway instead of

You need also to remove the second static route: ovpn.

I wouldn’t have thought so, I assumed you’d want the outer network gateway, but I tried it anyway and the change had no effect.

Here’s my routing tables after making the change:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default       UG    0      0        0 tun0
default         UG    10     0        0 eth0.2        *        U     0      0        0 tun0     *        U     0      0        0 br-lan UGH   0      0        0 eth0.2       UG    0      0        0 tun0     *        U     10     0        0 eth0.2

Can you share your firewall screenshot

Remove the static route and enable the option:

1 Like

Okay! I upgraded to the v4 beta and ticked that setting and now it works just as needed. Cheers!