Samba authentication problems

I have a GL-AR750S and despite I believe having configured everything fine I can’t access my router/usb hard disk attached to it neither from windows nor from iOS from within the LAN

i can access the usb hard drive with ssh but the router/samba does not even show up in windows file explorer.
The router does appear in ios with a file explorer app but then i can not access the shared directory

Below my share template

what do you think the problem could be?

netbios name = |NAME|
display charset = |CHARSET|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
browseable = yes
deadtime = 30
domain master = yes
encrypt passwords = true
enable core files = no
guest account = nobody
guest ok = yes
invalid users = root
local master = yes
load printers = no
map to guest = Bad User
max protocol = SMB2
min protocol = SMB2
min receivefile size = 16384
null passwords = yes
obey pam restrictions = yes
os level = 20
passdb backend = smbpasswd
preferred master = yes
printable = no
security = user
smb encrypt = disabled
smb passwd file = /etc/samba/smbpasswd
syslog = 2
use sendfile = yes
writeable = yes

I am not a samba expert, but I also have an AR750S and have it sharing a micro sd card with samba on the network. I had problems because I wanted to require a password for access to some of the shared folders. Are you trying to use passwords or simply have open access to the drive? Also, do you have a share specified?

I found that using the Luci (Advanced) configuration gave me more control. To use it, you first have to install the luci-app-samba package. You can do that from a ssh login with “opkg update” and then “opkg install luci-app-samba” while connected to the internet. This needs to be redone after every firmware change. Reboot after the install and the configuration can the be found in Luci Services → Network Shares.

As for your config, the differences I see are that I have the following settings:
netbios name = GL-AR750S
display charset = UTF-8
interfaces = lo br-lan
server string = GL-AR750S-198
unix charset = UTF-8
workgroup = WORKGROUP
Note that they are explicity set.

I also do NOT have the line:
min protocol = SMB2

My share looks like:
path = /mnt/
read only = no
guest ok = yes
browseable = yes

The min SMB2 may be the problem as I believe that Linux, OSX, etc. might still be using SMB1. I use Linux, Android, and OSX and can connect with all of them.

If you are trying to use passwords, there are other changes needed.

Hope this helps.

Thanks Mainer

I don’t need passwords, in fact I don’t even want them, but I thought a user / password was needed for samba to work
I inserted the min protocol SMB2 upon suggestion of people in another forum , the reason being windows does not deal with SMB1 any longer

I am already using the samba configuration in Luci, which as you say can be found under network shares, I find the template rather useful.

Ok. My wife just verified that she can access the GL-AR750S mount point and folders using Win10. Win10 File Manager prompted her to turn on Network Discovery, and she set it as a Private network.

When I was setting up with passwords, I could see the shares but not access them if I had anything in the “Allowed users” field Luci → Network Shares. I assume that your shares are showing up on that page. Settings there should be Browsable and Allow guests (read only if you want).

BTW for share/samba/usb changes, the router needs to be re-booted for them to take effect. There is no auto-mount when the usb is inserted.

With the default settings, my 750S gave access as specified in Luci with no need to change any configuration files using ssh. You might try reloading the firmware and going back to the defaults. I am now using the latest “testing” firmware without any problems, if you want to try that.

Are you using the official firmware? The official firmware enable samba by default, you don’t need to change the configuration file.