Script: Update Tailscale on (nearly) all devices

Downloading ‘
Connecting to
Redirected to /stable/tailscale_1.64.0_mips.tgz on
Connection error: Connection failed

I have also pinged, and I could communicate with it from the ar750s.

I don’t know why, but the server seems to block you. :sweat_smile:
Can you reach via your browser?

yes, i can reach it on browser while connected to the ar750s. can I download it and upload it to the router? Sorry, I’m not good with linux.

Thanks for your help!

Well yeah, but if you are not good with linux you shouldn’t do this. So we need to find out what’s wrong.

Please execute:

curl --head
ping -w 4
root@GL-AR750S:~# nslookup

Non-authoritative answer:        canonical name =

Non-authoritative answer:        canonical name =
Address: 2a09:8280:1::a:1a71

root@GL-AR750S:~# curl --head
HTTP/2 200 
accept-ranges: bytes
content-length: 25085737
content-type: application/x-compressed-tar
last-modified: Thu, 11 Apr 2024 18:55:18 GMT
date: Sun, 28 Apr 2024 17:50:39 GMT
server: Fly/92cd5373 (2024-04-28)
via: 2
fly-request-id: 01HWJX95AFM6K5YV799648EAJP-sea

root@GL-AR750S:~# ping -w 4
PING ( 56 data bytes
64 bytes from seq=0 ttl=57 time=6.115 ms
64 bytes from seq=1 ttl=57 time=6.218 ms
64 bytes from seq=2 ttl=57 time=5.968 ms
64 bytes from seq=3 ttl=57 time=6.177 ms
--- ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 5.968/6.119/6.218 ms

I added some fixes for your situation.

  1. Download the necessary archive.

  2. Copy it to the router as /tmp/tailscale.tar.gz

  3. Run the script with parameter --no-download

Single liner would be

wget -O \
&& sh --no-download

On the GL-MT1300 (I know not officially supported) it uses the MIPS package. However I had to tweak your script to install the mipsle as mips errors when trying to start (EOL errors).

TAILSCALE_VERSION_NEW=$(curl -s | grep -o 'tailscale_[0-9]*\.[0-9]*\.[0-9]*_mipsle\.tgz' | head -n 1)

All fine on mipsle now via

Also wget for some reason failed to download the binary (looked similar to what the previous commenter said). Using curl worked fine with me

    #wget -qO /tmp/tailscale.tar.gz "$TAILSCALE_VERSION_NEW"
    curl -f -L "$TAILSCALE_VERSION_NEW" -o /tmp/tailscale.tar.gz

Thanks it work, downloaded file and renamed and placed into /tmp

1 Like

Thanks, will look into this.

5 posts were split to a new topic: GL GUI does not work anymore

Asking around, I just updated my AXT 1800 to the latest version Tailscale using the script provided above, was working fine before with the last version of tailscale, now the custom exit node does not work at all. Also, tried to re-bind device and I get an error stating "operation timed out" and just hangs there trying to do something. I try binding thru SSH and with the link it provides me and seems to "bind device" but again the "custom Exit node" seems not to be working on my end. I've have no trouble with connecting to my all my sites if I use any other devices. Just wondering if anyone had any issues after this latest update with their routers?

Custom exit node is only supported if you modify the startup scripts since the option isn't provided by default in the GL firmware. You need to add the corresponding argument to the startup script then.

Thanks for the response and what should be looking for? (kinda a network noob here).

Like i mentioned earlier, it was working for me without any issues until I updated to the current version of Tailscale is when this issue popped up.

Need to vi into /usr/bin/gl_tailscale and add --advertise-exit-node to the following line which is right at the end of the file. Then just reboot or presumably restart tailscale and it will show up as an exit node.

/usr/sbin/tailscale up --reset --accept-routes $param --timeout 3s --accept-dns=false > /dev/null

If I misunderstood this and you meant using another exit node I only got that working by using the mullvad addon. Never tested another exit node so not sure if it will properly detect those but I was able to use the mullvad addon in testing and select the router then it showed up with a list of IPs to use as an exit node for the router.

1 Like

Yes not using the router as a exit node but using it to connect to other exit nodes within my tailscale network.
Like I mentioned, it was working fine until the latest update to Tailscale that I ran into this problem

Could it be due to the issue I reported here? MT3000 - Internet breaks when upgraded version of Tailscale Exit Node is enabled

Looks like the other poster had the same problem that I am having too, I tried the command the poster listed for the MT3000 and it didn't seem to work for me on my end...

If this is the cause of my problems, how would I revert back to TailScale v1.64.0 since it was the last version that worked for me?

Thanks for bringing this to my attention.

I integrated a fix to modify the GL scripts for tailscale so activated exit nodes shouldn't be a problem anymore. Please rerun my script to update.


Thanks @admon for making this script!

Updated my Flint 2 just now with it!

Will this work on a GL-X3000? I am getting the security vulnerability error for version 1.58.2-1 which came with the most recent Firmware.