Script: Update Tailscale on (nearly) all devices

Should work on every device, so give it a try :slight_smile:

Yup works perfectly. Awesome - thank you!

Never had an issue with @admon script until today when I attempted to update my MT3000/Berly AX.

This is the error I receive:

root@GL-MT3000:~# wget -O update-tailscale.sh https://raw.githubusercontent.com/Admonstrator/glinet-tailscale-updater/ma
in/update-tailscale.sh \

&& sh update-tailscale.sh
Downloading 'https://raw.githubusercontent.com/Admonstrator/glinet-tailscale-updater/main/update-tailscale.sh'
Connecting to 2606:50c0:8003::154:443
Connection error: Connection failed
root@GL-MT3000:~#

Seems like you can't connect by IPv6 - maybe disabling it on the router can fix this.

Thank you @admon I Enabled IPv6 on the router and then disabled it. I ran your script again and it worked flawlessly.

1 Like


thanks! Works well!:+1:t2:

1 Like

Just did this on a Flint2 and it works well (I have 1.66.4 now). Thanks

1 Like

One thing I would like to ask the author: Is it possible to make the exit node stay active and not stop advertising after a restart or after some time? This is the script I used to turn it on:

tailscale up --advertise-exit-node --accept-dns=false --accept-routes

Thanks a lot

1 Like

The script was updated to use pre-built tiny tailscale versions, which will save plenty of space. On MT6000 (Flint2) the difference is from 40 MiB to 6 MiB! :partying_face:

3 Likes

Thanks @admon do you recommend running the script again since you updated it?

Yep, totally recommend!

1 Like

love the script / works great
but can I gently suggest a different colour, other than yellow?
It's very difficult to read to following, for example:

┌──────────────────────────────────────────────────┐
| Are you sure you want to continue? (y/N) |
└──────────────────────────────────────────────────┘

Yellow is bad to read but the white is fine? Or do you use a light terminal with black font?

yes / On MacOS, standard is white background with black text.... however I updated my terminal settings to make my background black...

FWIW on a Mac - open Terminal.
Choose Terminal ->Settings -> select, "On startup, open: (select from dropdown) PRO

This will turn your background to Black...

It's strange that Tailscale update script doesn't detect the latest version v1.68.1 ?

image

No, it's not weird. The tiny tailscale version is build based of the latest release available on GitHub. Since Tailscale did not update the version there, the newest version isn't available yet.

You can use the big binaries by adding --no-tiny or you simply need to wait until they update the codebase.

Thanks for the explanation.