SD card Exroot Command

I am trying to mount my sd card as /overlay on MT1300 but it never works.
I used the mount points option though luci but I shows like this

I also tried using the Exroot command no luck

Is there something I am doing wrong or am I using the wrong drive?

The /overlay mount point for /dev/mtdblock6 is still active.

I do not work for and I am not directly associated with GL.iNet

hmm what you could do is try to start from 0.

And then use mkfs.ext4 /dev/mmcblk0p1 (assuming this is your sd card, always double check) to format it in case there are orphaned/older packages from a older version of OpenWrt otherwise you may get into compatibility issues/softlocks, it litterly does what it says overlaying the current partition, on my Mochabin that is one reason why I splitted partitions to not lose all files :yum:

Now what you need to get is a opkg called block-mount and then you type block detect | uci import fstab this generate a mount configuration on /etc/config/fstab.

Now what you need to edit is:

You copy the entries of the mmc and the only thing you change is target '/overlay' and enabled to 1, then reboot.

On my Mochabin this works fine :+1:, I think the wiki mentoid above also describes this.

I used an older extroot method and it worked.
I will say something this you should be able to do this straight from Luci.

1 Like