Seeing No Clients on WireGuard Server, no internet

I have the Linksys Mesh Router connected to the GL-1300 Slate Plus (Firmware 4.2.1), which I am using as my WireGuard server. I have the GL-MT3000 Beryl AX (Firmware 4.2.2) as my client.

This is my client configuration:
Address =
ListenPort = 9873
PrivateKey = [redacted]
MTU = 1420

AllowedIPs =,::/0
Endpoint = (my ddns)
PersistentKeepalive = 25
PublicKey = [redacted]

I did setup DHCP reservation and port forwarding for the GL-1300 Slate Plus on my Linksys Router.

I confirmed the GL-1300 has internet access. I saved the client config file and turned on the server. I have it using my DDNS.
I go to the GL-MT3000 and have it connected to my iphone mobile hotspot. I confirmed it does have internet and am able to browse. I went to WireGuard client to upload the client config file. I started the client and it shows that client is starting… and when I go back to the WireGuard server on GL-1300, its showing No Clients and not seeing any up/down. I also don’t have any internet either…
Here’s the client log:
Sat May 20 20:18:51 2023 user.notice firewall: Reloading firewall due to ifdown of wgclient ()
Sat May 20 20:20:37 2023 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-GIVEUP SHLVL=1 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Sat May 20 20:20:37 2023 daemon.notice netifd: Interface ‘wgclient’ is now down
Sat May 20 20:20:37 2023 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Sat May 20 20:20:37 2023 user.notice mwan3[16201]: Execute ifdown event on interface wgclient (unknown)
Sat May 20 20:20:37 2023 user.notice firewall: Reloading firewall due to ifdown of wgclient ()

It seems to keep repeating the same messages in the log, which leads me to believe something is wrong. I can’t tell if its something related to my Linksys router settings, the Wireguard Server, my iphone hotspot, or the Wireguard client.


Normally the address in the interface section would be a /32 to define a single IP. /24 is a range. Also the ListenPort is not really necessary as the Client will pick a port to use.

What is your server configuration.

The problem is in the port forward settings. Pls post the screenshot of your port forward to check.

Most of the reasons:

  1. Didn’t set up port forward at all. I met a lot of cases that someone said they set up correctly according to the docs but refuse to give any screenshots. When remote support I found that they didn’t set port forward at all.
  2. Be sure to save and apply the port forward settings in some routers. Otherwise it may be unsaved settings and does not take effect.
  3. Wireguard should use UDP, not TCP. Or you can choose both.
  4. Don’t change the ports. Just use 51820 for both external and internal ports. Of course if you know how the ports work you can change.
  5. Ddns may be wrong. Check if the ddns is resolved to your real IP.
  6. Some ISP has an extra firewall setting to allow remote access from wan side. Otherwise the port forward does not work.

WOW! I can’t believe it! I went to my linksys settings and saw that my port forwarding settings never actually saved! I just did the following now… and its WORKING!!! thank you!

This is how I setup my port forwarding. I used single Port Forwarding.

Just verified the connection IP as mobile hotspot IP vs Home IP… and finally… it works!!!

1 Like

I added yours to #2. I do observe such issues.

Wireguard is only UDP. It’s OpenVPN where you can choose, but UDP is still preferred.

Is there a reason I am getting slow speeds when connected to the server? It’s struggling to connect for a speedtest and then I get about 5mbs, at which 8mbs was the highest I got after 10 attempts. This is when I have my vpn client router (MT3000) connected to my mobile hotspot on my iphone for internet.

What is the upload speed of your ISP cable? That is the download speed cap when you use as server.

This is what I’m getting on my hotspot. I connected my iPad to my hotspot to get the results.

Not the hotspot. Need to check the ISP cable speed on your vpn server side.

I connected to the GL-1300 Slate Plus and turned the server on. I ran a speedtest and you’re right, it’s extremely slow. What could be causing this? How can I increase the speed? My actually home internet is usually over 300mbs.

I have Spectrum internet. I just setup free no-ip this morning for my DDNS properly. If that is not necessary, let me know. I figured I would need it in case Spectrum changes my IP.

I was setting this private VPN so that I can travel remote and not be detected I’m out of the country. Do you suggest I use something like NordVPN? I’ve been reading mixed reviews about the different service providers. I need one that will be reliable enough to not flag me at work. Although, I don’t know how strict my company is…

You should connect to GL-A1300 directly, via wifi or cable. Don’t touch the vpn server as it does not matter. Your pc should not have any vpn configured. Then test the speed, which is your ISP speed.

The speed you posted is absolutely not correct.

I did connect to the A1300 via Wi-Fi on my computer. When I connect to my home internet I get download speeds of 300+ but my upload is around 8-10. If your previous statement is true, then it’s about right that my connection to the server is around 5 or less based on my upload speed.

I’m now considering another vpn provider that will allow me to connect to it and get a dedicated server. I just tried purevpn but then it states glinet does not work with purevpn dedicated ip server. Might try nord vpn tomorrow or forgo the idea of a dedicated vpn. I don’t know.

OK. But why the download speed in your figer is so slow? How does A1300 connect to your ISP router?

Maybe you can just ask your ISP to give you a better upload speed (which is the download speed cap of vpn) other than use 3rd party vpn.