Set WWAN-sta to static IP permanently (GL-AR 750S)

I have the following scenario:

goal: The wireless “internet” needs to be set to SSID with static IP address.

Problem: As soon as the network signal drops it changes from static to DHCP

Went to Advanced → Network → Interface and configured it with appropriate static address.
It works.

but as soon as I move it which requires me to walk through the dead zone, it comes back as DHCP.
I logged in as root and checked /etc/config/network file and confirmed it.
Is there a way for the system to not change this file (I tried making it read-only but then it changes it back to rw and modifies static to dynamic)?
Or what config I should do so the interface stays static as configured and when the network is visible again it connects to it.

Hope this is clear but if not, I will be happy to clarify

Please try disable the gl repeater manager.

/etc/init.d/gl_health stop
/etc/init.d/gl_health disable