Setting MTU Size on Beryl Router and Slate AX

I have both a Beryl and Slate AX. Both of them will only ping at an mtu size of 68 max. How do I alter the settings for MTU size and troubleshoot this issue? Could it be the main router? Trying to figure out.

Also, what is this? Menu_hwnat I see it as an option under Network in the admin panel.

How did you check the mtu? 68 is not possible I think.

The MTU of the interface you can check in LuCI → Network → Interface → Device.It is 1500 by default.

Which version of firmware are you using? It should not appear in the admin panel of Beryl and Slate AX.

Ping -D -s 68 www.google.com on apple computer

4.1 beta for the Beryl

I went into Luci and this message popped up.

This is what ChatGPT had to say. Is it correct or did my router get hacked?

Me: You are a technical support wizard and I need help with my gl inet router. opened up Luci for my glinet router and it says network ifname configuration migration. The existing network configuration needs to be changed for LuCi to function properly. Upon pressing continue ifname options will get renamed and the network will be restarted to apply the updated configuration

ChatGPT:
It sounds like you are trying to access the web interface (LuCI) for your GL.iNet router and are encountering a message about network ifname configuration migration. This message is indicating that the current network configuration needs to be updated in order for LuCI to work properly.

When you press “continue,” the ifname options in your router’s configuration will be renamed and the network will be restarted to apply the updated configuration. This process is a normal part of updating the router’s firmware and should not cause any problems with your network.

However, it’s important to make sure that you have a backup of your current configuration, in case you need to restore it later. And it’s also recommended to have a wired connection to the router during this process and to have a device that can connect to the router via a wired connection in case of any unexpected problems.

If you’re still facing issues or have any doubts, it’s best to consult the GL.iNet router documentation or reach out to GL.iNet support team for further assistance.

1 Like

If you are opening LuCI for the first time, this is normal and it needs to be synchronised with the configuration.

1 Like

It isn’t the first time.

Wow. ChatGTP give the correct answer.

2 Likes

I don’t know MacOS, but in windows, I use the following to detect mtu

ping 8.8.8.8 -f -l 1428

1500 is the mtu for data send via the Internet.
1428 is generally the mtu for carrier networks
If you use vpn, the mtu is even lower

But 68 is not possible.

1 Like

I found an mtu setting under VPN! But, this is my ping result:
.250.78.164: icmp_seq=11 ttl=111 time=241.347 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=12 ttl=111 time=264.429 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=13 ttl=111 time=282.520 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=14 ttl=111 time=301.852 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=15 ttl=111 time=331.655 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=16 ttl=111 time=211.926 ms

wrong total length 96 instead of 128

76 bytes from 142.250.78.164: icmp_seq=17 ttl=111 time=220.441 ms

wrong total length 96 instead of 128

@alzhao Can we just update these in the FW so we don’t scare everyone who goes to Luci / Network / Interfaces ?

This does pop up regularly!

On the AXT1800 FW4.2.3 what happens after the migration is:

option device '@wan'			-> option ifname '@wan'
option device '@tethering'		-> option ifname '@tethering'
option device '@wwan'			-> option ifname '@wwan'
option device '@modem_1_1_2' 	-> option ifname '@modem_1_1_2'

Should be innocuous and so it has been stated by some team member (can’t find the related post…), please have a dev check this and update it!

Everyone who goes there wonder if it’s safe or not, prevent users headache! :sunglasses:

Thank you!

I don’t see how one could do that in /etc/config/network given interface uses device. Eg:

config interface 'wan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wan'

IMO if they’re going that deep into LuCI they could just as easily head over to OpenWrt’s forums.

AXT1800 f/w 4.2.3-r5.

It’s already in the development plan.

1 Like

If i dont use VPN, i set the MTU to match the ISP Router and seems the connection is blazing fast now. Thanks you very much @alzhao ! For my router, it is 1492.

When using VPN, it seems the MTU is lower like 1472 in my case. Do I need to adjust the MTU setting in the ISP router to match the MTU with VPN?

1 Like

No, you don’t need to adjust the MTU. It’s only the VPN MTU - which is inside the “real” network MTU already.

1 Like

Much appreciated! FYI, i only use AR150 router now. And the speed is much better using Wireguard protocol. It is midnight here though, I will report if the connection is really stabilizing.

The last time I checked it does not make it past 3-4 Mbps. Now for the first time it is 20.1Mbps upload speed!

update: i set the MTU right from my device (e.g Playstation4). The GLInet is only used for VPN.