Setting up a wireless bridge with GL-B1300


#1

Generally I know how to setup a wireless bridge with Oprenwrt. The GL-B1300 should replace an old TP-Link, which works as wireless bridge client (wds), but doesn’t have 5GHz.

Firmware of the GL-B1300 is 2.272 and Chaos Calmer 15 .05.1, I read about problems with stp-mode, which should be solved with the latest version. So do I have to flash first?

I want to configure the GL-B1300 with a wired connection. I could not get a connection with the LAN-Port. The PC had the IP 192.168.8.120, but I could get a wireless connection with a notebook and 192.168.8.1

Do I need the advanced configuration for a wireless bridge? I have to configure 2 wifi-iface.

For configuration I am following https://openwrt.org/docs/guide-user/network/wifi/atheroswds The master access point is a TP-Link TL-WR1043N/ND v1.8 (Atheros AR9132 rev 2) with OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152) and works fine with other TL-WR1043N/ND v1.8 openwrt-18.06 as Clients.


#2

Using firmware 2.272, WAN connection, repeater, and selecting WDS mode should fit your need.


#3

Thank you, but I don’t understand why I should use wan connection.

To make it clearer, I have a tv without wifi, but with ethernet. So I want to connect the tv via ethernet to the B1300 and then the B1300 should connect to another wifi-router (TL-WR1043N as mentioned above).

I cannot connect the B1300 via ethernet to my LAN.

A 2nd task will be the access of a mobile phone to the B1300.


#4

To use ethernet bridge mode you do need some advanced configuration.
First stop dhcp server of b1300:
uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq restart
If you need to use the wan port as lan,
uci delete network.wan
uci delete network.wan6
uci set network.lan.ifname=‘eth1 eth0’
uci commit network
/etc/init.d/network restart
Please see if this fit your need.


#5

Yes, I know, that I need an advanced configuration. I need something like below (from a working other router).

The question is, can I do this with the default configuration method and if I need the advanced configuration, do I have to flash the router, because my other routers including the master ap use OpenWrt 18.06.1, while the B1300 uses openWrt 15.05.1

How can I configure the B1300 with a ethernet-cable? Do I have to use the wan or the lan port. With my TP-router it works with the lan-port, with the B1300 I have no connection with the wan-port.

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ‘11g’
option path ‘platform/ath9k’
option disabled ‘0’
option channel ‘5’
option legacy_rates ‘1’
option country ‘NZ’
option htmode ‘HT40’

config wifi-iface
option ssid ‘Pa04’
option encryption ‘psk2’
option device ‘radio0’
option mode ‘sta’
option bssid ‘aa:bb:cc:dd:ee:ff’
option key ‘pw’
option wds ‘1’
option network ‘lan’

config wifi-iface
option device ‘radio0’
option mode ‘ap’
option ssid ‘Pa14’
option network ‘lan’
option encryption ‘psk2’
option key ‘pw’


#6

I cannot answer your question about using WDS with different versions of OpenWRT. But let me first clarify your request/need.

You are trying to connect your TV, which has no wifi, but does have an ethernet cable, to your existing home network.

Please clarify: Are you doing this just so that your TV is connected to the Internet, e.g. you can use Netflix or Youtube on your TV?

Does your TV need to communicate with other devices in the house, e.g. a smartphone remote, or can it be on its own subnet, i.e. unable to connect to other devices in your house, but can still get Internet?

Based on this comment:

To make it clearer, I have a tv without wifi, but with ethernet. So I want to connect the tv via ethernet to the B1300 and then the B1300 should connect to another wifi-router (TL-WR1043N as mentioned above).

it seems that you simply need your B1300 to serve as a wireless client. If that is the case, there are several ways to configure. I prefer the luci interface, and can walk you through if need be.

However when you say

A 2nd task will be the access of a mobile phone to the B1300.

it is clearer that WDS is what you want. I am also trying to setup a WDS with my new B1300, so perhaps we can figure this out together.

As best as I can tell, the easiest way is to use the GL-inet interface, then follow the second post. While it is counter-intuitive that you would be going into a WAN setting, this is how GL-inet has done this UI (note that they already have an updated UI in Ver 3 of their firmware, not yet ready for the B1300). In your case, you would scan for the SSID of your TL-WR1043N, put in the correct password, and select a LAN IP within the subnet of the TL-WR1043N.

I just tried it, connecting to two different APs in my home, and it just works. It is interesting to go into the advanced settings (luci) and see all the configurations which are done as a result.

It seems that you can even have different SSIDs for the “master” and the “client”, although of course the channel is locked.

Let me know about my questions and how things stand on your side.


#7

where do i get exact information on wireless networking issues