Setting up file sharing on AR300M-Lite

Merry Christmas!

Here is the smb.conf.template file that I set up and works on my GL-AR300M16-Ext, with the 3 lines changed:

netbios name = |NAME|
display charset = |CHARSET|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
browseable = yes
deadtime = 30
domain master = yes
encrypt passwords = true
enable core files = no
guest account = nobody
guest ok = yes
invalid users = root
local master = yes
load printers = no
map to guest = Bad User
min protocol = SMB2
max protocol = SMB2
min receivefile size = 16384
null passwords = yes
obey pam restrictions = yes
os level = 20
passdb backend = smbpasswd
preferred master = yes
printable = no
security = user
smb encrypt = disabled
smb passwd file = /etc/samba/smbpasswd
syslog = 2
use sendfile = yes
writeable = yes

I don’t think min protocol = SMB2 is critical and I set it to avoid accidentally using SMB1 on a client.

The “security = user” is critical and SMB2 did not work when it was the original “share” value.

I forgot that I switched from ES File Explorer to the Solid Explorer app some time ago. Android Solid Explorer lets you choose SMB1 or SMB2 when you first map the file share and I always choose SMB2, which the app recommends.

With the modified smb.conf.template, both Solid Explorer and Ubuntu accessed the GL-Samba file share on my GL-AR300M16-Ext.

If you do NOT set min protocol = SMB2, then ES File Explorer and Linux may work. However, SMB1 is not recommended.


Oh my gosh!! Thank you so much @wcs2228

So - it all seems to work if I set
max protocol = SMB2 (It would NOT work for some reason with this at SMB3)
security = user

I don’t have to login to the share - no credentials required and I get read/write permission.
No concerns in my use case but I was expecting it to require me to login.

And you are correct - ES Explorer does not work without allowing SMB1 protocol
But Solid Explorer works fine.

Anyway - that’s it! Merry Christmas and thanks so much!

1 Like

Thanks for this solution, I can now able to access the files on linux mint. However, while adding the router address, I ticked the anonymous option.

Is there a way to add additional user/password support, since we are not using SMB1.