Setting up file sharing on AR300M-Lite

Running a AR300M-Lite for a hotel router while traveling. Been working well for a while.

Upgraded to new firmware - 3.215 today.

I was just trying to do some file sharing from a USB - planning ahead in case I need it.

I enable file sharing but the 3 labels for the file sharing are not there
but looking at File Sharing - GL.iNet Docs
seems like they are Share via LAN, Share via WAN and Writeable.

I enabled the top two.

Running nautilus in Linux I try to connect to
smb://WifiSSID/share and I get a login screen
I try Admin and my admin gui login screen password.

Anyway - nothing seems to work.

Is there a package I can remove/reinstall to get the slider labels to show up?

Any other tips/tricks?


You need to use username “root” and your login password. Nor “admin”.

The docs actually have this.

Thanks alzhao - I will try root as my username.

But pretend I am dumb and don’t have this all figured out - point me to the docs. I think I am really close though so - maybe a few more pointers…

  1. Are you saying is that I have to do the steps shown in the Windows section and ssh into the GLI and edit the samba config file?

  2. If I can just use nautilus - then use username = root and use the admin password that I use to login to the gui at

  3. Do you have any thoughts on why the text for the slide switches don’t show up on my GUI? Or better yet how to solve that?

  4. New question - can I do a reinstall of the F/W and if so - is the warning about keeping my settings just overkill or can I keep my settings and save from going back to 0.

  5. Will the GLI power an NVMe M.2 SSD that I have in a case? My testing so far has been with a standard USB flash drive but just curious

Thanks again!

NO. This is for windows.

Pls try.

Now sure what you mean. Pls give images.

If you have problems, try reset the firmware, not reinstall. Unless you bricked the router, try reinstall using uboot.

Maybe not. The mini router is not powerful enough.

1 Like

Thank you thank you for taking the time to break this down for me!!

1: got it
2: not working -
Added info that I don’t think matters but just in case:

  • I changed my LAN IP to - for no real good reason other than keeps the kids away.
  • I have dns set to a custom - Quad9 - I enjoy having different people selling my data??

In Nautilus typing in anything like - smb:// or smb:// or anything it immediately gives me:
Unable to access location
failed to mount windows share: Software caused connection abort

3: Here is what I am talking about. In the category File Sharing - I am guessing what slide switches I am enabling. Not sure why the text isn’t there.

Everything else is working for me and I already got my wireguard clients in and everything.

But if I wanted to fix this - what do I try next?
Thanks in advance

Can you log into the router via SSH, run the following commands and post the output:

ls -l /mnt

I think the router uses “GL-Samba” as the default share name.

Regarding #3, I have seen and posted about the missing/blank labels on my router also, which is shown in the doc.

I do not work for and I do not have formal association with GL.iNet.

1 Like

I see the problem in the UI. Yes it is a problem in some versions.

As we are upgrading all to 4.x we are not fixing the display error in File sharing.

Thanks everybody for getting back to me.

Sorry that I missed the slider switch text was a know error. But thanks for confirming the switches work and it is just a superficial thing.

I ssh’d in and ran the commands and got:

root@GL-AR300M:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                10496     10496         0 100% /rom
tmpfs                    61792       368     61424   1% /tmp
/dev/mtdblock5            3712      3128       584  84% /overlay
overlayfs:/overlay        3712      3128       584  84% /
tmpfs                      512         0       512   0% /dev
/dev/sda2                51082      6176     44906  12% /mnt/sda2
/dev/sda1              3679452   2603068   1060000  71% /mnt/MX-Live-usb
root@GL-AR300M:~# ls -l /mnt
drwxrwxrwx    8 root     root          4096 Jan  2  2021 MX-Live-usb
drwxrwxrwx    4 root     root         16384 Jan  1  1970 sda2

Yes - I am using a thumbdrive that has 2 partitions on it and I was running MX-Linux with it. Not thinking that should cause any issues. Actually - I went in and viewed my grub.cfg file on the MX-Linux distro just to make sure - so the GL-I has no issues with the drive.

If anyone gets here with a similar problem - Yep - I did have to add a config file in ~/ssh directory
following these directions here: SSH to the Router - GL.iNet Docs .

Using nautilus and trying to connect to smb:// or smb:// gives me the usual error.

I went ahead and took a look at my smb.conf file.

        netbios name = GL-AR300M                                               
        display charset = UTF-8                                                
        interfaces = lo br-lan                                                 
        server string = GL-AR300M-79d                                          
        unix charset = UTF-8                                                   
        workgroup = WORKGROUP                                                  
        browseable = yes                                                       
        deadtime = 30        
        domain master = yes                                                    
        encrypt passwords = true                                               
        enable core files = no                                                 
        guest account = nobody                                                 
        guest ok = yes                                                         
        invalid users = root                                                   
        local master = yes                                                     
        load printers = no                                                     
        map to guest = Bad User                                                
        max protocol = SMB2                                                    
        min receivefile size = 16384                                           
        null passwords = yes                                                   
        obey pam restrictions = yes                                            
        os level = 20                                                          
        passdb backend = smbpasswd                                             
        preferred master = yes                                                 
        printable = no                                                         
        security = share                                                       
        smb encrypt = disabled                                                 
        smb passwd file = /etc/samba/smbpasswd                                 
        socket options = TCP_NODELAY IPTOS_LOWDELAY                            
        syslog = 2                                                             
        use sendfile = yes                                                     
        writeable = yes                                                        
        comment     = Home Directories                                         
        browsable   = no                                                       
        read only   = no                                                       
        create mode = 0750                                                     
        path = /mnt                                                            
        read only = yes                                                        
        guest ok = yes                                                         

I would love to tell you that I understand that all but it looks like you are right - the share is named GL-Samba. I edited the smb.conf.template to allow SMB3 as max protocol. Seemed worth a try anyway. Restarted samba and still couldn’t connect - same error. Confirmed the new smb.conf file shows max protocol of 3.

Anyway - We are over my head skill wise at this point but still no file sharing.

Let me know if there is anything I should try next.
Thanks again !!

As for my question 5

Yep - I ssh’d into the GL-I and could NOT see this NVMe drive. I confirmed a handful of other USB’s but looks like with this cable and power supply combination I can confirm this does NOT work for me.

Obviously if that becomes a NEED for me I will get a powered usb hub. Guessing that should work just fine.

Thanks again!

The easiest next step is probably to delete 1 of the 2 partitions and start again.

If that is not feasible, look in the /etc/config/samba file and look for the sambashare name(s), then try connecting to smb:// name).

SMB2 or SMB3 should work with Linux.

CRAZY… Just for giggles I plugged another NVMe drive in. I don’t recall what makes this one much different. I think it is smaller? But the case is different.

But same power supply and same cable powering the GL-I and I can see the files on that drive through the GL-I so it DOES work.

Your mileage my vary.

Doing some more data gathering - I just clicked on ES File Explorer on my android phone and clicked in search for network drive.

It found GL-AR300M and I am now watching Field of Dreams from my second NVMe drive on my phone without issue.

So does that mean I suck at Linux and trying to guess share names within Samba? If so - the GL-I is working fine?

The power required by a NVMe drive depends somewhat on the drive model and how much of a reading/writing workout you do on it. There is still some risk that the power is marginal and may result in data corruption.

Does the second NVMe drive only have 1 partition on it?

Is there a command inside ssh I can run like htop or ?

There should be top in SSH.

This NVMe has 4 partitions. It is a drive pulled from a Windows laptop.

The GL-I is mounting them all automagically.
The boot, the windows recovery, the windows partition and a windows user partition.
Nice. I got some old movies.

Anyway that all seems to work in Android. But I try to add them as samba shares in Nautilus and I get:
Unable to access location
Failed to mount Windows share: Software caused connection abort

I have other samba network shares at my buddies house. I don’t remember doing much different than this. Starting to think I need to be on a Linux blog since it seems the GL-I works perfectly… with my phone and not my pc :hot_face:

Yes - top works in SSH. I was wondering if there is a similar command that you can think of that would show the power consumption or voltage so I could monitor to see how close I am to corruption trouble on the NVMe drive…

Thanks again @wcs2228 - got me this far. Any chance you are a linux guy too and want to get me all the way there?

I did some testing on my GL-AR300M16-Ext.

With 2 partitions on the USB flash drive, things did not work all and SSH showed that the 2 partitions did not get mounted. This can probably be done manually in SSH, but I did not proceed further.

With 1 partition on the USB flash drive, things looked good after I selected the correct mount point from the Current Directory drop-down in the File Sharing page. Android ES Explorer found the GL-Samba share, but could not access the share when I chose the SMB2 protocol that I normally use. When I went back and chose the SMB1 protocol, ES Explorer was able to access the share. Did you chose SMB1 or SMB2 when you used ES Explorer?

I also tried to access the share on my Ubuntu laptop and got the *Unable to access location failed to mount windows share" message that you did. I suspect that the main problem is that Ubuntu requires at least SMB2 and the router Samba is using SMB1.

When I had enabled SMB2 on another GL.iNet router, the /etc/samba/smb.conf.template file had to be modified by changing:

max protocol = SMB2
min protocol = SMB2
security = user

It worked on Ubuntu after the above changes.

I do not know of an OpenWRT utility that shows watts/voltage to the USB port. If you are only streaming/reading lightly from your NVMe drive, then you may be okay.

Excellent. That makes perfect sense.

Merry Christmas by the way.

When I get a moment - I will move my min protocol up to 2. I didn’t even think of that. Makes perfect sense.

Basically I am getting the same thing. ES file manager works fine in Android. I can pick any partition I want. Linux gives my that other error.

I will change that setting and see what happens.

As for the watts/volts - I did some more testing - I mean I streamed a movie to my tablet from the NVMe drive and it worked without troubles. The command top showed the cpu was not taxed or struggling to do it. If the need arises - I think I will just plug it in.

Anyway - thanks again and I will report back when I can as to the results.

Thanks again,

Merry Christmas!

No more time this morning but… @wcs2228 - when you get a moment can you send your complete smb.conf.template file?

I fiddled around with a bunch of things - I can get ES Explorer working and I can break it - with regularity now…
My ES Explorer never asks for the SMB mount protocol so…

At one point I had my Linux laptop connected… don’t remember exactly what I did…
But ES stopped working so I fiddled again and broke everything and then got it back to where ES Explorer is working again. But I since haven’t gotten Linux back connected.

I think it is a SMB minimum thing or security = share vs security = user thing.

Anyway - when I have more time I will fiddle some more but until then.
Take care!
And thanks again!