Setting up GL-MT300N with a USB wireless adapter for Bridge (WISP) mode

Hey Gang, I bought a GL-MT300N with the goal of using it as my primary travel router. I also have a small USB wireless adapter that I got w/ my Raspberry PI. WHat I would like to do is the following:

  1. Use the USB wireless adapter w/ the 300N so that I have two radios to handle WISP mode (one to contact the wireless AP that I want to share out…and then the other wireless radio to actually share out the signal using my own SSID/WPA2 key. My understanding is that having two wireless adapters is better so you don’t have to share one radio w/ amongst the incoming (say hotel wifi) and outgoing (the SSID I want to use to share the signal w/ my devices) signals.

  2. How do I set up my MT300 to bridge (I think that’s the proper term) one wireless adapter to another?

  3. Once I have all that working, how do I enable OPENVPN so my traffic is encrypted from device))) (((( 300N Wireless Adapter 1 300N Wireless Adapter 2 )))))) (((((( Hotel Wifi–> (Note: I already have a PIA subscription)

Hope this makes sense.

Thanks in advance for all your help.

Been there, done that.

Pretty much your device as delivered will do what you need. It should have the goodlife AP already configured and then you can use the GLI GUI and connect to a “Repeater” as GLI calls it in internet settings. It works, it’s easy. It does not answer your question.

Dual Radios. - Search OpenWrt forum for a post with edimax 7811 and rangerz. There are definite advantages to two radios. there are known issues with getting locked out of your device when the STAtion that you were connected to is no longer available (wireless hangs). Two radios does solve this. There are a number of reports that the actual performance is slower with 2 radios than with one. I have had mixed results, but in general agree. Not sure if it’s USB or what. Some report that separating the USB adapter by distance (ie USB extension) helps. Contrary to my post I get better speed with one radio.

Now you need to deal with the lockout issue. Two basic approaches.

  1. Use a script to kill the wireless either on boot or with a button action. I prefer the latter. You can get a script here:
  2. Use a tool to manage your configs. I use this one: but there are a number of others. Read the original posts on OpenWrt I reference. Depends on need.
OpenVPN - I use it to connect to my home server. It's 1 package, 2 with the luci app. openvpn-openssl, luci-app-openvpn

Install from command line. You may get an error from the GUI. Not sure on this device. In my time using it, I have not stayed in a hotel with more then 2.5Mbps (unless I want to pay more), so performance is poor, and worse with VPN. With a good connection I can get about 7Mbps with a cable on one side.

OpenVPN references:

Another issue to be aware of is the Wifi Access Pages. You need to login, but redirects to these pages is not always automatic or clean. Sometimes it’s plain old manual. I usually just add a shortcut to my desktop for the hotel. I am also of the opinion that, at least in the hotel I most frequent, that using the device leads to lease shorter than the hotel indicates.

Thanks for the detailed reply.

Will the GL UI allow me to set up VPN? I think it can (I see it there) but when I try to import some PIA Open VPN profiles…no go.


@Traveller, seems there are further bugs with PIA config. You can give me your log which is displayed on the openvpn setup page so that I understand why.

When you 2nd radio works, just use the UI to connect to another router as repeater. It will use the main radio. Then turn off the ap in the UI for the main radio. You need to setup the 2nd radio as ap manually. Everything should be fine.

@alzhao: I would love to…but I don’t see a log section in the Open VP area of the GL UI…and if I head to advanced, I don’t even see an area for Open VPN :frowning:

according to the guide:!openwrt/ , you should have problem in any one of the steps, no?

When I hit the Open VPN page, I see attached image VPN0


When I check enable and hit apply. The status changes to PLEASE WAIT…and nothing more happens. (Attached image VPN2)

It stays at the PLEASE WAIT status and my connected clients lose internet connectivity.




Seems I understand the problem.

First you need to upgrade to 2.19 to have log on the UI.

Second, other users already reported that “SPACE” in ovpn names will break the connection.

So, can you upgrade to 2.19 first, when you got the log of errors, change the name of the ovpn if needed. I have to correct this bug in next version.

I updated the unit to the latest firmware (2.19) when I took it out of the box yesterday…so I am current.

Yup…there are spaces in a few of the imported Open VPN profiles. Is there a way to delete them all and let me start over once I fix the file names? Or will a hard reset to the unit remove them?

Now you need to ssh to the router then do

rm -fr /etc/openvpn/*

Welp. The unit is now dead.

I wanted to clear out any bad stuff I had done - so I uploaded firmware 2.19 to the unit (to overwrite anything I had done and to start new) and now the unit is not responding.

I held down the reset button for more than 8 seconds. Nothing. No reset that I can tell or anything else is happening.

When I reset the power by pulling the micro usb out the putting it in again, all three lights come on for a moment then just the power light stays lit. I have no wireless signal and if I connect to the LAN or WAN port via CAT5 I get a address.


Right now the unit is a brick.


Am I screwed ?



I think maybe because of the repeater mode. When it cannot connect to the main router, its signal dead.

But the reset button should just work. Press and hold longer, for example 10 seconds, then release. The leds should flash in a pattern.

If anything don’t work out, use uboot: Debrick via Uboot - GL.iNet Docs

Thanks - was able to get back in via Uboot and have uploaded 2.19 again (I uploaded the wrong firmware - that is what caused the temporary bricking. I am an idiot)


So I am back at square one with firmware 2.19 on the device and access to the UI. I will work on getting OpenVPN added now.

More problems w/ adding OpenVPN to the router:

I download my PIA Open OVPN files

And since the current firmware does not like spaces in the names, I went in and removed all the spaces. Not when I try to import one or all of the OVPN files I get an error that “Cannot find correct ovpn files!”

Any ideas?

Pls use the testing firmware 2.20 from /firmware/testing/

it does support spaces in names.

Great news. I updated to 2.20 and was able to import the PIA .OVPN files. I have confirmed I can connect to PIA VPN on the device.

My intentions for the device are much like the OPs, and I’ve done what you suggested with repeater mode and now I’m seeing other wireless clients connected to me. I assume that’s because it’s “repeater more” and not what I know as a client-bridge (which makes my unit a client of another AP and bridges that to my LAN).

Are the clients I’m seeing other people, or something inherent to the repeater mode? If others, how would I setup a client-bridge so the only SSID broadcasting is mine, which my devices would use?

Thanks in advance.

To set up a client-bridge mode, you need to use either WDS or relayd.

For WDS mode, your main router need to support WDS as well.

For relayd, it is software bridge so no need wds. Just setup a WISP mode and you need to install and configure relayd.