Setting up two GL.Net routers for VPN purposes

Hello. I am traveling overseas from US to Europe. I need to connect to my home network in US in order to be able to work from EU. I have a 1gig download/upload speed and a public IP which is a dynamic IP. I purchased a GL-AX1800 / Flint and GL-A1300 / Slate Plus.

I replaced my main router with the Flint and set up the Wireguard Server. I changed the routers default IP from 192.168.8.1 to 192.168.0.1 because I had different security devices working on my old routers IP 192.168.0.x.
(I tested the Wireguard VPN with an android Wireguard app and it works, although the speed is usually 30-40 Mbps, when I disconnect from Wireguard, I am getting over 200Mbps on mobile data. Sometimes the speed while connected to Wireguard is less than 1Mbps)

Now, I was struggling with getting the Slate Plus router set up to work as a Wireguard Client.
I followed the steps from this link, up to point 6, I skipped 7-10, I have no idea how to do it and if it’s necessary:

So basically:

  1. Started the Wireguard VPN server with DDNS (due to dynamic IP) on Flint
  2. Created a new Wireguard client and copied the configuration on Flint
  3. Connected to Slate Plus and changed the routers IP from 192.168.8.1 to 192.168.10.1
  4. Created a manual Wireguard Client and paste the config
  5. Connected to the Server

I also added both routers under GoodCloud and created a network with Flint as Main Node and Slate Plus as Node 1.

Then I unplugged the Slate Plus from the Flint and tried to see if it works. I unabled tethering on my phone, connected my it via USB to Slate Plus, opened Admin Console and connected to USB-Tethering Android. It showed as being connected. The IP Address was showing as 192.168.193.12, Gateway and DNS Server both showed the same IP 192.168.193.25. I tried to connect my laptop to the Slate Plus wifi but it was showing no internet. Then I opened the Slate Plus admin console again and went to WireGuard Client tab, the dot was yellow and would not connect to the WireGuard server, on top of the page it was showing “No internet connection! Find a network to reconnect.” The laptop still wouldn’t connect to Slate.

I would really appreciate if someone would help me get it set up because I am leaving in less than a week :frowning:

Here I am logging into the router via SSH to change the configuration. Do you have any knowledge of OpenWrt or Linux?
For non-technical people, we recommend GoodCloud’s Site to Site.

Sorry, I don’t understand here, are you referring to using the Site to Site feature provided by GoodCloud?
image
The working status of Site to Site is not currently displayed on the firmware UI. You should check its working status on GoodCloud.

Pls post with images so that it is easy to follow.

Pls use the cloud managed solution which is much easiler

For the SSH, I am stuck on #7 in the instructions, I am not sure how to add the subnet 192.168.10.0/24 to the client_ip

Here is all my configuration:

Home Router/Server - Flint




For Travel Router/Client - Slate Plus





And this is GoodCloud:



Server Router:

Client Router:

Using Site to Site on GoodCloud does not require the VPN Client/Server to be enabled in the firmware UI. if I disable the VPN Client on Slate Plus, will it display online on GoodCloud?

Yes, it is showing online when I disable the VPN Client. However the speed is extremely slow, and I am right next to the main router. I can only imagine how slow would it be if I’ll be over 5000 miles away.

Is it better to use Wireguard VPN setting or GoodCloud?

Does the client IP need to be changed in SSH?

I only have 2 days to get it up and running, otherwise I’ll have to return to my old setup and just use Tailscale and Cloud VPN which is much faster than GliNet with my current settings.

Are you referring to the slow access to the router’s administration page from GoodCloud, or the slow access between the two Site to Site? The data between Site to Site is not forwarded from GoodCloud, GoodCloud only sends the configuration. Please check the speed between Site to Site.

GoodCloud also uses WireGuard to provide Site to Site, but with automatic settings. There should be no difference between the two.

The speed is much faster with SitetoSite when I turned the WireGuard VPN off. However with this, I am not able to use my phone with the Wireguard app.

I there any way of adding a smartphone to S2S?

Can I use both, the WireGuard Server and SitetoSite?

Also, the USB tethering only works for a few minutes and then it is automatically disconnected in the Travel router settings.

Sorry, it was not supported yet.
If you must use your mobile phone to access it, you will have to use a manual configuration solution instead of S2S.

The configuration file is usually edited with the vi command.

vi /etc/config/wireguard_server

If you are not familiar with vi, it is recommended that you change the ssh tool. Some ssh tools support opening and editing files in a graphical interface. For example MobaXterm.

That requires the routing table to be set up manually. It is very complicated.

Okay so I cannot use S2S with both the router and smartphone?
Also, I cannot use both S2S and WireGuard Client at the same time?

I am leaving in an hour so I won’t be able to configure it anymore, the instructions of setting it up are very unclear and almost impossible to do for a person that is not good with networking. I think I will skip Gl.iNet and go with my previous setup.

Yes, smartphone or other WireGuard Client can’t added S2S.
Sorry, S2S only support add router yet.

I am already abroad and testing the router. It does not work with Good Cloud S2S, it worked while I tested it in US but it’s not working overseas. I am getting a message “The following two devices, the WAN IP of the first device is conflicted with the LAN IP of the second device”

The VPN works when I enablem the WireGuard Client on my travel routers. It also works with WireGuard VPN being enabled and S2S being enabled as well. Are you sure that I cannot use both S2S and VPN?

I did not add the client IP in SSH. What would I actualy need that for if it works without it?

The message tell you to change the IP. If you have access to both routers, you need to change the LAN IP of the second device to others.

But I suggest that you post details of your setup, e.g. IP of each nodes, wan status of each nodes.

Please check the LAN and WAN subnet of the two devices. For example, the IP of device 1 is 192.168.8.100 and the LAN range of device 2 is 192.168.8.0/24, which will be in conflict.

WireGuard supports access to other clients, but S2S does not provide quick configuration for this. You have to modify the WireGuard configuration file manually.
In addition, mentioning that S2S has modified the WireGuard configuration after the configuration file has been manually modified may result in unintended consequences.