Setup wireguard using console in GL-AR150

HI

I’m testing wireguard service to use GL-AR150 to connect to a wireguard server. Testing using dashboard is not a problem using WAN and WLAN at same time, but using commands seems that something fails because start service but breaks interface, and I don’t know in this router which are the requirements to enable wg. seems that only creating wireguard.conf file is not enough

All commands used was

uci set wireguard.@proxy[0]=proxy && \

uci set wireguard.@proxy[0].main_server=‘vpn’ && \

uci set wireguard.@proxy[0].enable=‘1’ && \

uci set wireguard.wg_peer=peers && \

uci set wireguard.wg_peer.name=‘vpn’ && \

uci set wireguard.wg_peer.address="${ADDRESS}${MASK}" && \

uci set wireguard.wg_peer.listen_port=‘49258’ && \

uci set wireguard.wg_peer.private_key="${PRIVATEKEY}" && \

uci set wireguard.wg_peer.dns=‘10.200.200.1’ && \

uci set wireguard.wg_peer.end_point=‘34.244.124.181:51820’ && \

uci set wireguard.wg_peer.public_key="${PUBLICKEY}" && \

uci set wireguard.wg_peer.allowed_ips=‘0.0.0.0/0’ && \

uci set wireguard.wg_peer.persistent_keepalive=‘25’

start the service but lose the connection. we need to create some changes in network config or routing system?

You can read /etc/init.d/wireguard for some useful information.