SFT1200 - 5GHz Wi-Fi not going above 230Mbps


I’m having trouble reaching my real internet speeds over Wi-Fi with the SFT1200 router. Via wired Ethernet, a speed test on fast.com gives me the full speed from my ISP (500Mbps), but when connecting to the router via 5GHz Wi-Fi, I only get around 230Mbps maximum. I have disabled 2GHz just in case, and tested with my phone right next to the router, but the speed doesn’t change.

I don’t believe it to be an issue with the device I’m connecting with, as if I connect to my ISP router’s Wi-Fi connection with the same device, I get the full 500Mbps speed.

Firmware version 4.3.11
Wireless settings:

I tried setting the channel to auto and a few others manually but it has no effect.

Any advice or suggestions would be much appreciated. Thank you!

What client are you using?
Can you change Wi-Fi mode to 11ac only?

Tested with Pixel 8 Pro and M1 Macbook Air, both have the same result, even with mode forced to 11ac.

Pixel 8 Pro and M1 Macbook Air are 2x2 MiMo, so supports two spatial streams, so the max sync rate should be 866.7.

What is the shown sync rate on both clients?

Both show 866 Mbps as the receive/Tx link speed.

Is the internet connection PPPoE or IPoE/DHCP?

DHCP. My ethernet setup is like this, if it matters:

Openreach ONT (modem) <—> eero Pro 6 (router) <—> TP-Link TL-SG105 (switch) <—> GL-SFT1200

ok, if you add iperf3 to the sft1200, via opkg add iperf3 or via the web interface, grab iperf for the Pixel 8 Pro or Macbook: ‎iPerf 3 Wifi Speed Test on the App Store

then run the app connecting it to the iperf3 running on the sft1200

Ran it on macbook, 5 streams for 30 seconds.

177 Mbits/s
min: 58
max: 224

Repeated it a few times, roughly the same results. This is still while being right next to the router.

so iperf3 has removed the WAN interface, so this is a local issue.

@admon is there any GL.iNet staff around who can advise if there’s been any changes to the siflower wifi proprietary driver between 3.216, 4.3.7 and 4.3.11 stock firmware?

The only bug fix I can see that may have an impact is Hardware Acceleration introduced in 4.3.11:

Fixed a conflict with GL-SFT1200 between PPPoE protocol with VLAN ID and hardware acceleration

Cracked open a new sft1200, 3.212 was installed, updated to 3.216.
running iperf3 and using he.net tools I’m struggling to break 60 Mbps

Bump, still experiencing this issue