Shadowsocks Disappearing after GL-B1300 Upgrade

I’ve been using the GL.iNet GL-B1300 router with Shadowsocks and ChinaDNS. However, I noticed that the firmware was upgraded to 3.022 and my existing services/settings related to shadowsocks are all gone!

I was trying to install it again. When I click on the “Update” button on the “Plug-ins” page, it’s loading forever and doesn’t seem to work.

Please help! Thanks

I haven’t tried the update myself. I’ll give it a try when I get home this evening. Thanks for the heads up

I can install gl-ss plug-ins on “Plug-ins” page on GL-B1300 v3.022.
I think that was the network problem you can not update the “Plug-ins”, please try again later.

Can’t find gl-ss because I can’t finish updating the add-ons.

I’m in China right now. It seems like updating is really slow and can never finish. I tried manual command “opkg update” and it looks like the the file “” can’t get downloaded at all.

Please help. Thanks!

updating repo in China should work. It is slow but should not be blocked. Hope you can try again.

Because even if you downloaded, you will need multiple other packages for dependencies.

You can use OpenVPN or Wireguard to across the wall to update the add-ons.

I tried that. The new version can’t add new OpenVPN config (after uploading the file and entering the username, passwd and hit add, nothing happens). And Wireguard doesn’t work (it’s showing connected, but there’s connection to the internet. Can’t visit any site.).

For openvpn, it seems this problem is caused by your Antivirus software.

For example Bitdefender blocked you to input password to http web site. Make an exception.

Thanks! I’m using Bitdefender. Do you know how to let is allow password on non-https sites? Can’t figure it out…

I was able to add a couple of openvpn profiles after making exceptions on my antivirus software. However, it looks like openvpn doesn’t work in China (which was the why i was trying to set up shadowsocks).

Is it possible to fix your plug-ins update script URL or network issues so that users in China can easily update plug-ins? So far it’s been really painful.

I have to say that this is not easy to solve. We do not support these functions in China and we will not use server for this in China as well. Sorry for this.

I finally got plug-ins updated and was able to install gl-ss. However, I’d like to set up Shadowsocks to bypass websites in China. I installed the chinadns plug-in, but I don’t know how to set up SS to bypass China IPs using the main interface. Any advice? Thanks!