SIM card not registered GL-X750

Hello , I’m having a problem with my GL-X750 4g/3g router , i insert sim card and it fetch the ISP name and configuration but it shows Sim card not registered i followed many topics here but no luck ,

My ISP Name is Omantel
here is a screenshot

I need your help please

I have replied to you by email and need you to check some status

i sent you all details you asked for

in case other people get same problem i uploaded all details you asked for and here is screenshots , please let me know how to solve this problem .


Revision: EC25AFFAR07A06M4G




+QNWINFO: No Service


+QCFG: "band",0x260,0x4,0x0


+QCFG: "nwscanmode",0


+QCFG: "band",0x260,0x2000000003300185a,0x1


Operator name




+CREG: (0-2)


and QCFG

+QCFG: “gprsattach”,(0,1)
+QCFG: “nwscanmode”,(0-8),(0,1)
+QCFG: “nwscanseq”,(00-0102030405),(0,1)
+QCFG: “servicedomain”,(0,1,2),(0,1)
+QCFG: “roamservice”,(1,2,255),(0,1)
+QCFG: “band”,(0-200),(0-7FFFFFFFFFFFFFFF),(0-7FFFFFFFFFFFFFFF),(0,1)
+QCFG: “rrc”,(0-4)
+QCFG: “cops_no_mode_change”,(0-1)
+QCFG: “msc”,(0-2)
+QCFG: “sgsn”,(0-2)
+QCFG: “hsdpacat”,(6,8,10-24)
+QCFG: “hsupacat”,(5,6)
+QCFG: “pdp/duplicatechk”,(0,1)
+QCFG: “tdscsq”,(0,1)
+QCFG: “airplanecontrol”,(0,1)
+QCFG: “ledmode”,(0-2)
+QCFG: “ehrpd”,(0,7)
+QCFG: “usbid”,,
+QCFG: “usbee”,
+QCFG: “usbnet”,<0-3>
+QCFG: “usbcfg”,,,,,<at_port>,,,,
+QCFG: “urc/ri/ring”,(“off”,“pulse”,“always”,“auto”,“wave”),(1-2000),(1-10000),(1-10000),(“off”,“on”),(1-5)
+QCFG: “urc/ri/smsincoming”,(“off”,“pulse”,“always”),(1-2000),(1-5)
+QCFG: “urc/ri/other”,(“off”,“pulse”),(1-2000),(1-5)
+QCFG: “risignaltype”,(“respective”,“physical”)
+QCFG: “urc/delay”,(0,1)
+QCFG: “agps/string”,(0,1)
+QCFG: “cdmaruim”,(0,1)
+QCFG: “cmux/urcport”,(0-4)
+QCFG: “ModemRstLevel”,(0,1)
+QCFG: “ApRstLevel”,(0,1)
+QCFG: “ltectcc/smsstorage”[,(0,1)]
+QCFG: “noauthcheck”,(0,1)
+QCFG: “nwscanmodeex”,(1-63)
+QCFG: “oostimer”,,,
+QCFG: “diversity”,(0-1)
+QCFG: “ppp/termframe”,(0,1)
+QCFG: “nwoptmz/acq”,(0,1),(60-16777200)
+QCFG: “ims”,(0-2)
+QCFG: “pcmclk”,(0,1)
+QCFG: “tone/incoming”,(0,1)
+QCFG: “rssi”,(0-20)
+QCFG: “cdmasms/cmtformat”[,(0,1)]
+QCFG: “ltesms/format”[,(0,1)]
+QCFG: “amrcodec”,(0-255)
+QCFG: “apready”,(0,1),(0,1),(100-3000)
+QCFG: “sleepind/level”,(0,1)
+QCFG: “wakeupin/level”,(0,1)
+QCFG: “urc/cache”,(0,1)
+QCFG: “thermal/modem”[,,,]
+QCFG: “thermal/limit_rates”[,]
+QCFG: “thermal/txpwrlmt”[,<on_off>,,<temp_threshold>,,<trig_cnt>,<crl_cnt>]
+QCFG: “lte/bandprior”,(1-43),(1-43),(1-43)
+QCFG: “codec/powsave”,(0,1)
+QCFG: “qmisync”,(0,1)
+QCFG: “disrplmn”,(0,1)
+QCFG: “vts/async”,(0,1)
+QCFG: “urc/ri/pin”,(“uart_ri”,“uart_dcd”)
+QCFG: “iproute_enable”,(0,1)
+QCFG: “imsreg/iptype”,(0,1)
+QCFG: “stkauto/setupmenutr”,(0,1)
+QCFG: “eps/guti_enable”,(0,1)
+QCFG: “qcautoconnect”,(0,1)
+QCFG: “ftm/mbim”,(0,1)
+QCFG: “volte/disable”,(0,1)
+QCFG: “gpsweek”,(0,1)
+QCFG: “multi_ip_package”,,<package_max_len>,<package_max_count_in_queue>,
+QCFG: “sim/onchip”,(0,1)
+QCFG: “siminvalirecovery”,(0,1),(1,60),(1,30)
+QCFG: “sleep/datactrl”,(0-7),(50-5000),(0,1)
+QCFG: “plmn/autoblock”,(0,1),(1-0xFFFFFFFF)
+QCFG: “sim/clk_freq”,(0,1)
+QCFG: “sarcfg”,(“lte_wcdma”,“gsm”),max_power,row_grads,column_grads
+QCFG: “efratctl”,(0,1)
+QCFG: “plmn/addinfbdn”,(0,1)
+QCFG: “Feature_Switch_Flag”,(0,1),(0x01 – 0xFFFFFFFF)
+QCFG: “icf”,(0-3),(0-3),(0-3)
+QCFG: “dhcppktfltr”,(0,1)
+QCFG: “ntp”,(1-10),(5- 60)
+QCFG: “freezeband”,(0,1)
+QCFG: “bootup”,,(0,1)
+QCFG: “poaccept”,(0,1)
+QCFG: “divctl”,(“lte”,“wcdma”),(0-2)
+QCFG: “rrc/control”,(0,1),(0-60),(0-60),(0-300),(0,1),(0-60)


Please execute the following AT command


I’m having the same issue with this router. When I use a friend’s sprint sim it works fine. But my t-mobile sim says not registered. Let me know what type of information you need to help me. Thanks

T-Mobile not registerred? Does you SIM requires a specific apn?

Pls check if the apn is input correctly.


I used , ( included in the software drop menu too) for the APN . I also tried all the ports. Like I said I tried a friend’s sim for sprint and it worked. My T-mobile phone sim has unlimited phone data no hot-spot data.

Thanks for the help. Chris

I am surprised your friend’s Sprint SIM works without issue. In my experience most Sprint and T-Mobile plans require the IMEI to match what was registered with the SIM. I would search the forums for a few commands that will allow you to change the IMEI on the GL to match your phone for testing purposes. Search for TTL mangle as well since your phone does not have a hotspot plan.

A quick thank you for the help.

I encountered the exact same issue as above. The sim card suddenly doesn’t work anymore. I updated my firmware to the latest 3.104-3.217 for x750v2. But it doesn’t help.

I finally made it work but to my surprise that the firmware (even before update) shows me that luci is not installed. I must have installed it because I need to change the TTL settings to make the sim card work at the first place.

I just played around with the APN setting (plus adding back the TTL setting) and finally it started to work again. I believe the TTL setting might be critical to be correct as well. It sounds to me the firmware somehow uninstalls the luci itself or who remotely uninstall the luci? I have no idea why.

This issue shows up again and it seems the carrier issues. My other carrier sim card works. Actually the sim card that doesn’t work on the 4G router works on iphone se very well. It can surf the internet with the iphone but cannot be used with the 4G router.

After a whole day of hotspot with the phone, I reset the modern on the 4G router (x750) and change the APN setting back and forth, and it works again. What the hell the problem is!

" SIM card cannot be registered. Please check: 1. You are using the compatible modem for your carrier; 2. Whether a specific APN or data plan is required."

Do you have any specific APN, pin code?

Do you need to change the IMEI on the router to make it work?

It seems that the carrier is blocking you to use on the router.