Site2Site with two GL-MT300N-V2 (Mango) Wireguard

Hello from France,

We are on holiday and I am trying to set up a safe and leak free site2site WireGuard connection.

The basic setup was easy and the WireGuard Server is running on my GL-MT300N-V2 at home. I can connect with several IPads and Iphons without any problems.
Now I bought a second GL-MT300N-V2 and and it connects without problems to the Server as well.

But…I do have two problems where I am asking for help.

  1. I need to restart the client Router daily, otherwise I can’t surf.
  2. If I run dnsleaktest.com (extended) it shows me a DNS Server from the Netherlands, even the WireGuard Connection is established.

Can you help me solving this issue? I’d like to have a safe site2site WireGuard connection.

I really appreciate any kind of help with this issue.

Pizzi

Pizzi

Do you know about goodcloud.xyz from Gl-iNet? 2 click setup wireguard s2s

And in goodcloud you can reboot, ssh, web access and more.

Do you want all the client traffic goes through the server or not?

If yes, you should use client and sever settings. Upgrade to the latest firmware 3.203. 3.201 has a DNS leak.

If no, you should use Goodcloud to set up S2S. Each node can access other node but Internet goes via its own ISP.

I didn’t really look into the goodcloud yet.
My original plan was to to everything on my own and not use a provider. I would prefer having no third party involved.

I want all the traffic going through the server.
Save and without any leaks.

I did upgrade both sides to the latest firmware but there is still this Server from NL where I don’t have a clue where it comes from, we’ll it must be on the clients side.

What could I have done wring that it still leaks?

For the firmware pls use 3.203 https://dl.gl-inet.com/firmware/mt300n-v2/v1/

It fixed a dns leak problem. You can also turn on vpn policy and make sure “use vpn for the processes on the router” is turned on.

It was my fault.
Works as designed now…

1 Like