Sky Q & VPN No Downloads

Has anyone got advice how I can get Sky Q to work on my GL-AX1800, I use SurfShark wireguard, I can view catch-up etc but the Sky Q refuses to download, I tried using the client not to use the VPN but that seems worse as if there is no DNS server but that’s just my take on it so hope that don’t mislead you.
I also have a Roku Ultra and that prefers the VPN if I pass that direct to the isp with no VPN it acts like the Sky Q and doesn’t stream.

Regarding Roku, it locks the region according to the country associated with your account. You can try to reset the Roku, turn on VPN to connect to another country, and create a new account in that country. Subsequently, you should be able to turn on VPN to that country and connect the Roku.

There are websites that describe the step-by-step procedure to do this.

I do not work for and I am not directly associated with GL.iNet

Many thanks, on the Roku that’s working fine using a VPN its just the Sky causing me problems, even using the correct country.

Some streaming services block known IPs from the more popular VPN providers and there is unfortunately no way around it unless these providers keep on changing the IP in a game of cat and mouse or you purchase a dedicated IP address different from the one available to the wider user population.

Thanks for the reply, what I I don’t understand is using the VPN Policy Base on the Client Device selecting the option Not Use VPN and selecting the Shy Q’s MAC address and save it still don’t like going through the router any ideals, I also have the Global Options set to all off the only thing I’m not sure of is the settings I should have in the DNS settings under network.