Slate 750m upgraded, now unresponsive

Purchased Aug 14, 2020. A couple hours of use <20hrs. Most of its life has been in protective case. This was my “emergency backup” router.
Upgraded to latest version (took multiple interim upgrade steps)
Ran overnight. Seemed stable, happy next morning.
Disconnected, moved to location to put into more regular day-in day-out service.
Power applied, left power light only. Then, other lights, then off, then repeat.
Tried on a number of 2a power supplies. Same same.
Reset MANY times. Nada.
Will no longer provide ethernet wire DHCP address. No WiFi, which makes it inaccessible.
I guess one would call it bricked.
Any magic incantation to breathe life back into this? Options?

Potential for this is AMAZING, however not of any use now.

Try using Uboot to install the previous version that was working. I just stay with Firmware 3.203 on my GL-AR750S-Ext.

I do not work for and I am not directly associated with GL.iNet

1 Like

Thanks @wcs2228. We’ll give it a whirl! Fingers crossed!

Thanks again, @wcs2228. We’re back in business! WooHoo! Took your advice running 3.203.
Notes: I did NOT upgrade Uboot. Had as described the “single-file-non-confusing version”, so tried it, and it worked. The video led me to believe that the reboot would take place in maybe 3 minutes - it took 25 minutes to reboot - and worked after that.

As I need to bring a personal router to each site I work, my go-to router has been a very reliable Apple Airport, and the Slate AR750s EXT has been my backup. I’m still a bit untrusting of the Slate. I may trade places and make the Slate primary, with the Apple Airport as my trusted backup. (and carry a third… belt and two sets of suspenders…)