Slate AX 4.2.0 beta2 - Multi-WAN DNS problem

I have a multi-WAN setup, where repeater has the highest priority.
The secondary connection is trough PPPoE, in failover mode.
Well, this is the problem: The Slate AX is in fact using DNS from repeater AND PPPoE connection at the same time, mixing them.
Also, I don’t have any indication of the DNS that are used on the UI:

I actually tested this on 4.1.0 stable, 4.2.0 beta2 and the latest snapshot (2023-01-31).

Thank you for your feedback, we will test it.
How did you verify that it is using DNS from both sources?,, are all reporting multiple dns hosts from both WWAN and WAN.
Also when Slate AX mix the DNS, streaming services like Prime Video stop working.
The Slate AX is repeating from a Beryl AX wich is running Wireguard Client (ProtonVPN).
I tried to uncheck “Use DNS servers advertised by peer” on the WAN PPPoe interface and using custom DNS but it’s stil mixing them, so I ended up setting simply and I enabled Adguard Home as a temporary solution.

1 Like

Have you been able to reproduce the behaviour?
I just tried Beta3 and the problem is still there…

Does this also happen if you set up a DNS server manually on the page?

No, if I set DNS manually all is fine, but it’s problematic because I am using a Wireguard client from Beryl AX WWAN, so I should manually set wich of course doesnt work with PPPoE conection. Using a 3rd party DNS also works but it breaks too many thing with ProtonVPN Wireguard (e.g. streaming services, security cameras playback…).

When you upgraded did you keep setting or load a config file in LuCi?
Check edit host in DNS settings?
Was Uboot Updated?
The VPN Config file could have DNS servers it using
If you installed a VPN APP on a device it might have had DNS Servers hardcoded.
In Multi-WAN is forced refresh streams enabled?

Is the Beryl AX up to date on firmware and packages(34 for upgrade usually)?

No, I did not keep settings.
All I did (after firmware upgrade without keeping settings) is giving the repeater the highest priority in Multi-WAN settings, then connect to to the repeater and to PPPoE. That’s it.
I noticed the problem since beta1.
Refresh streams in Multi-WAN is disabled and Beryl AX is running the latest firmware.
Wireguard is not the problem, even if Beryl AX is not running WG client, I still have mixed DNS between the 2 sources (WAN & WWAN).

Is this set to the lowest priority

I Think a work around is playing with the the “failure Conditions” and “avaliable Conditions” in the Multi-WAN settings for each interface.

In LuCi check the Dhcp and DNS settings, there are options like strict order and list DNS Servers.

I am thinking that the resolv file is using a particular queuing order or parallel request for the DNS

Thanks, I already tried playing with failure conditions and priorities with no luck.
Enabling strict order makes thing worse, with that option enabled the Slate AX is only using DNS from PPPoE ignoring the repeater.

Here’s the content of the file:

# Interface wan
# Interface wwan
search lan

When you made changes in Multi-WAN did you restart the service or restart the router?(Openwrt sometimes needs a restart when making changes)

On the Beryl AX is “overide DNS for all clients enabled”

This will be the ISP default DNS settings

The way you want the multi-wan setup seems kind of strange. You want the VPN connection to the repeater to failover to a non VPN connnection?

I almost think you want to use drop-in gateway or Wireless bridge.

The DNS from the interface uses the mechanism native to OpenWrt, and there is no priority between them.

If you have VPN enabled, the DNS from the VPN will have a higher priority. Set it manually as well. In this case, there should be no status of using different sources of DNS at the same time.