Slate AX firmware 4.1.0 beta 2 is out

The release note is kind of LONG :smiley:

Download here: https://github.com/gl-inet/gl-infra-builder/releases/download/v4.1.0_axt1800_beta2/axt1800.tar.gz

3 Likes

I get the following error when I go to Upgrade → Local Upgrade and load the file:

Unzip, Untar the downloaded file and choose the .tar file if you want to “UPGRADE” and keep settings, the other .img file is for Uboot.

Is the new Multi-WAN option working for you guys?
Everytime I try to click the tab “Multi-WAN” I get the message “Unknown error occurred. Please check the network environment or reboot the device.” and I can’t change the settings…

Finally dns issue if dns server is internal to wireguard network and vpn policies are active is resolved.
Thanks

1 Like

If I change the fan temp settings and apply them, then go back to the overview screen and return to the fan settings it always returns to 75. It does say success when I apply the setting but then returns to default

1 Like

Did you keep settings when upgraded?

I did a “dirty” update and so far everything it’s moving smooth, I’m loving the “system” tap

1 Like

No I never keep them, however I restored them through backup. And yes, seems that some of my settings are preventing the multi-wan function on the UI to work properly…
Anyway, resetting the firmware it works.
I’ve set the repeater to highest priority and it works, however when I connect with Wireguard client the priority is ignored and Wireguard is using the cable connection, not the repeater. If I stop the Wireguard client the connection uses the repeater again as the primary connection.

1 Like

Thanks for your feedback, we will check it.

1 Like

Thanks to you, it’s amazing to finally have Multi-WAN settings on the UI.
I just want to add this: as I said, setting the repeater to the highest priority works, but if I connect the VPN client, Wireguard start using Ethernet connection.
At this point, if I physically remove the ethernet cable, Wireguard start to correctly use the repeater connection and if I put the cable back it stay there… but stopping and restarting the Wireguard client makes it using Ethernet connection again…

1 Like

Do you start vpn before failover? Then it is a problem. VPN seems does not failover because the connection already built.

Will check if there is a solution.

VPN failover to different network may cause trouble, e.g. the vpn service disconnect your connection temporary.

Uhm… actually the failover when the vpn is started works absolutely great. Yes, there is a very brief disconnection but the vpn start working again in a few seconds, not really a problem.
The only problem I see right now is that the Wireguard client force the use of the ethernet connection even if the reapeter has higher priority. But once it’s connected, if I physycally remove the ethernet cable, the wireguard client “jump” to the reapeter and it works just fine… I hope I explained it well…

When set to REPEATER with the highest priority and Ethernet second, the correct case.

  1. If both are available, wireguard uses repeater
  2. If repeater is not available, wireguard uses Ethernet. When repeater is available, the wireguard switches back to repeater depending on whether the Forced Switch Interface is enabled or not
    image

Yeah, it should use repeater. But it’s using Ethernet no matter what when I start the client. That’s the exact problem. Even if repeater is avaliable and everything is working correctly BEFORE starting the Wireguard Client, as soon as it connects it chooses ethernet over repeater. Enabling the forced switch doesn’t change this behaviour.

This is a bug, we are fixing it.

2 Likes

Awesome news, Thanks.

I Just noticed that in 4.1.0 beta 2 VPN policies menu is working the other way round: if you choose “USE VPN” like in the picture, it means that is NOT using the VPN. Everything was fine on previous firmwares.

Yes. We reversed the select box.

So if the select box display “use vpn”, the domains in the list should use vpn. This is more visual intuitive.

In previous version it is exception list. So you need to think reversely.

As you said the select box display “use vpn” but in reality the domains in the list are NOT using VPN, so it the other way round. Just try it.