Slate AX GL-AXT1800 OpenVPN client cannot quit

Hi, I have created a OpenVPN profile with ProtonVPN but can’t stop using it or switch profiles. For some reason the Dashboard page doesn’t recognise that the client is connected. What can I do to fix this?


I can’t upload more than one image, please ask for more info when needed.

Nevermind, I did a factory reset and uploaded a new Openvpn config file. All works well

1 Like

It seems a bug though.

super annoying bug. rebooting doesn’t help. its an infinite loop without being able to stop. the “enable” simply disappears.

Can we get a fix for this ASAP or a workaround which doesn’t involve factory reset?

Reproduce: ProtonVPN using the glinet OpenVPN tutorial. enable and then watch as you can’t turn it off. I tried changing the behavior of the side switch to enable/disable VPN but it doesn’t make a difference and will not terminate the connection. enabling wireguard also fails

I used the same wireguard, enabled and disabled for mutiple times and it is fine.

This is what I am using Dropbox - openwrt-ipq807x-glinet_axt1800-squashfs-sysupgrade.tar - Simplify your life

Snapshot on June 27th. Can you check?

Sorry I used wireguard. Need to try openvpn.

Tested Openvpn multiple times and still OK.

Can you try the firmware I posted above.

Hi thank you for the quick reply. yes I will try it and report back. I’m sorry, I’m new here but is it normal for snapshots to be posted here via Dropbox but not shared on the products firmware page under snapshots?

I updated to that firmware while the VPN was stuck in the connected state. It still doesn’t let me disable. Maybe this only applies to the UDP country USA config with protonvpn?

Another update. I reset firmware and tried again using the snapshot. Still cannot stop openvpn. I also seem to get a network error constantly even though I’m connected. Here is a picture from my phone

I tried looking through the logs to narrow down exactly why the VPN dashboard doesn’t switch to the connected display. Nothing stands out. This does however seem to be the only thing preventing me from stopping the connection. If I enable the openvpn connection and do not navigate away from from the VPN dashboard, I am able to disable the connection. If I refresh the page or navigate to another area in the admin panel, I lose the ability to disable the connection. I am mostly using Safari on a Mac or iPhone but I have tested with Firefox also. I have no problems with wireguard whatsoever. I do notice this error in the above screenshot just keeps showing up every so often in the VPN dashboard though.

here is a photo of when I don’t navigate away from the VPN dashboard. It stays like this with the Unknown error popping up every so often.

Maybe it is a problem brought up during upgrade.

I am sure we fixed a bug like this and the firmware I posted should not have such problem.

Can you just reset completely and reconfig the vpn?

I have tried this several times. Resetting in the admin panel as well as holding the button for 10seconds. It still does this to me every time using openvpn :frowning:

Send me screenshot of your web panel → upgrade page.

Is it possible to do a remote check?

My apologies for not updating this thread sooner. @alzhao took a closer look and found the problem. I can confirm the issue has been fixed in the newest beta. The issue stemmed from having a lot of DNS/IP/PORT entries in the vpn config. The fix has allowed for more. Thanks again for the quick fix


Hi @iammackies , I have the same issue when I use OpenVPN with my GL-AXT1800. I am just wondering if you can show how @alzhao fixed this problem. Thank you very much in advance!

PS. I have tried to modify my *.ovpn file and deleted the duplicated IP/PORTs in it, and then the issue has gone. I am not sure if @alzhao used the same way to fix the problem or there is another way to solve it.

Alzhao patched the firmware so just download the latest beta. No need to edit anything on your end


I am just wondering if you can show how @alzhao fixed this problem. Thank you very much in advance!

I was never shown how to work around it. This was only the answer I was provided with. You can find the latest beta on the main firmware download page for the AXT1800

1 Like

Got it. Thank you for your reply!