Slate AX (GL-AXT1800) Wireguard Issue (REKEY-TIMEOUT)

Howdy, I received my Slate a couple weeks ago and got time to get it working today. I pulled in a wireguard config, and upon trying to connect it gets stuck in a loop with a REKEY-TIMEOUT error. I attempted several resolution fixes, but was unable to get them to work (Pulled in config from phone, tried resetting, saving as a file (.conf) and uploading, etc).

I then attempted to try a beta client version (4.0.2), which did not resolve the issue.

As a last resort I upgraded to the beta kernel (5.4), which after briefly knocking the 5Ghz radio offline, immediately connected to the wireguard server and started working.

I then rolled back to the initial firmware (re-downloaded from firmware page), and was back to the REKEY-TIMEOUT issue.

Is there a known issue with the current client/kernel version that has an open incident/ticket and is being worked on? Would love to get wireguard running on the stable channel version.

EZ Format List of Troubleshooting done:

  • Tried config from phone (vice-versa, on phone the config from the slate worked on the phone)
  • Tried saving differently / using .conf format (LF & CRLF)
  • Bumped client release version from 4.0.0 → 4.0.2
  • Finally bumped kernel from 4.4.60 → 5.4 and wireguard started working immediately
  • Rolled back to initial firmware/client and wireguard stopped working immediately
1 Like

Is this your own Wireguard server? How can I test the same?

I am facing exact the same behavior … @alzhao please bring this topic forward. Spent so much money for good hardware. :confused:

Previously you send me a config privately and it does not work in my Windows client as well.

If you have different case can you send me details?

I understand some people met REKEY-TIMEOUT issue but I still trying to replicate this problem in my side.

alzhao: sounds like a typical crappy excuse,

I have tried downloading multiple configs from providers as well. Famous VPN providers and they all have the same problem. So its clearly a bug in your firmware. An solution would be much appreciated for people who have paid 3 times the price of a normal router to get these functionalities, and all you can come up with is excuses. This has been happening with configs multiple well known vpn providers used by thousands of people also this has been repeatedly complained by people using variety of servers with all combinations, which work elsewhere without any error … Clearly the problem is in ur firmware. We are not here to provide you config we paid more and its your job. There are enough complains of ur buggy firmware and u should arrange your own set of servers/configs/device to test, and replicate… clearly its ur system

Come up with solution not excuses!