Slate AX (GL-AXT1800) Wireguard Issue (REKEY-TIMEOUT)

Pls try clean installation and Configure again.

I have done that several times. I have done the following:

  • Pressing the outer hardware button on the router for 10 seconds.
  • Using the admin UI, clicking on the “Reset Firmware” button.
  • Install a new version of a firmware (4.0.2).

The issue is not solved with any of these steps.

I was planning to buy an AX next week, now I’m unsure. Maybe the Flint would be safer

So seems that the wireguard does not work on your Andriod tethering now. Now sure what is the problem.

Not only on Android, but also with the iPhone.

Can you try change mtu as in this post

I did, but no success. Still same error:

Today I worked with @hectorricardo to solve the problem. Several problems are identified.

  1. The wireguard config from Starvpn use domain name as endpoint. The domain resolves to several IP addresses. Different network will resolve to different IP address. Some IP addresses does not work. When hard core to certain IP address, it works OK. So this is definately a problem of Startvpn. This is verified on windows pc as well.
  2. Two bugs identified on our firmware: (a) The firmware does not work well with two IP address in wireguard config; (b) not be able to edit wireguard config in @hectorricardo’s macbook browser. I can edit in my Chrome though.

1 Like

Luckily I found this topic.

New GL-AXT1800, facing EXACTLY same issue.

WG server is operational, same config exported to mac client works without any issues.

What I have tried:

  • replace server hostname with IP to exclude DNS related issues;
  • change VPN settings on AXT-1800 as some advised in the thread.

So far nothing helped, I am still getting REKEY-TIMEOUT.

You can send details to me to check.

All the issues I checked has a different reason.

@alzhao thank you - I’ll do that. What details you are looking for?

Pls read this post 4.x Wireguard REKEY-TIMEOUT troubleshooting

You can pm me your wireguard config, detailed network setup and issues to check. If the problem is you cannot connect to Wireguard at all, I think I can find the problem quickly.

1 Like

Sorry I don’t see how to PM on this forum. Am I have Pms disabled?

As for the configuration - I have set up Wireguard VPN on Raspberry using pivpn scripts. The raspberry is at my home network behind NAT, so I set up port forwarding for TCP/UDP. Wireguard uses non default port (but from very same range).

Moved AXT1800 out of home network and tried to connect - got REKEY-TIMEOUT. Thought something wrong with port forwarding, so brought it home, changed server name to local IP (192.168.1.x), tried same - got same response REKEY-TIMEOUT.

Then I decided to test the VPN - installed Wireguard client on my laptop, used same config as on AXT-1800 - and it connected in a second. Wireguard client on laptop works even when I am outside of local network, so port forwarding proved to be working fine.

At home AXT1800 is connected via WiFi to local network(192.168.1.x). All devices are connected to AXT1800 network (192.168.8.x), there is no problem in connectivity whatsoever.

Let me pm you and you can reply me.

I’ve been following this thread for a few weeks hoping to find a solution. I also have the REKEY TIMEOUT issue. Only using mullvad.

  1. New Slate AX 1800
  2. Tried multiple firmwares including the latest 4.2 beta 2.
    -Previous versions didn’t let me pull a mullvad config at all when putting in my account number.
    -4.2 allows me to pull the mullvad account from the settings page, but still have a REKEY TIMEOUT when trying to connect.
    -OpenVPN works
  3. Using the router at home, not 4G/5G
  4. Not using IPV6
  5. Not using DDNS
  6. Commercial mullvad service.
  7. Not using Adguardblock

Can you pm me to help resolve this issue?

I sent you a message.

I am closing this thread because it does not help to solve issues.

I was able to solve most of the issues that comes with me with details. Reasons include wrong server config, vpn service provider bug, ddns issue, UI related bugs, vpn cascading not supported in old firmware etc.

For more info pls refer to 4.x Wireguard REKEY-TIMEOUT troubleshooting

If you have issues of Wireguard connection, please

  1. Read the agove post
  2. Open your own thread with details.

After check. It is old firmware problem. After upgrade to 4.2 it works OK.

After check and deep test, seems the issue is related to parent router (which is a netgear) and mac address. When Slate AX cloned mac address of laptop or phone, wiregard connects. It does not connect with the original mac address. Nothing has been found in the netgear settings related to this. So it is still a mystery.