Slate AX Repeater AP Roaming

I purchased a Slate AX to accompany my family on a cruise. It’s been fantastic EXCEPT when moving around the ship (have it connected to a USB-C battery), it fails to roam to a new AP until it’s in the same location for several minutes. Is this by design? Anything I can do to improve it?

What channels do you use? If you use DFS-channels on 5 GHz it can take some time to scan the frequency.
I would recommend not to use DFS-channels if possible.

Are you referring to this option under the repeater options? If so, I have it turned off.

This is the configuration I use with my GL-A1300. Until today it worked in all 5 hotels and it didn’t matter whether password or captive portal.
5GHz WiFi is fixed to channel 48 and 40 MHz BW.
It connects at once and in repeater/router-mode I build my own network.
Wireguard works without problems.

@WolfP Thanks for the information. It’s working fine when in one area, but I’m walking around the entire ship with mine. My Slate does not stay connected when moving about my phone traditionally would.

If I stay in a single area, it’s working great. When traversing locations, it will not stay connected until I stop in a single spot for several minutes.

Maybe play with 802.11kvr a little bit. Don’t have too much experience in this myself.