Slate ax1800 and Hotspot

Hi all,

Apologies, messed up my first post and repeating here.

Just purchased the Slate ax1800 router and am trying to get it to work with the Solis 5g hotspot that has a T-Mobile sim card and gets 5G speeds. Connecting Slate to the hotspot via repeater mode. Updated the firmware to the latest.

When connected to the slate wi-fi my download speeds are 3 Mbps or less, and upload is anywhere from 10-20 Mbps, which seems really odd.

When connected directly to the hotspot I get the usual speeds of 70-80Mbps. I have confirmed this is purely a router issue, as I have connected the router to my home wifi and get the same slow results. Have also tried 5 vs 2.4GHz on the router and hotspot.

Not sure where to go from here. Are there some settings I need to configure? Wonder if it’s the hotspot itself? I did use usb tethering, usb-c on the hotspot, to the usb-a on the router. It did seem to bump up the speeds by around 1 Mbps. Any help would be appreciated!

Thank you!

Are you sure you tried 5G and also tried to repeater your home wifi?

No way to only have 3Mbps only!

You are correct! I apologize, I thought I was getting those slow speeds with my home wi-fi network as well, but I was wrong. So when the Slate is connected to my home wi-fi, I get the normal speeds, it works. It’s when it is connected to the Solis hotspot I’m having issues.

Currently, I’m getting an No Internet Connection error when connected to the Slate wireless network. This is with the Slate connected to the Solis hotspot via repeater mode. Should I try a different Network mode?

Appreciate the help, at least I’ve narrowed it down to the hotspot itself, thanks again.

I think I might know what the issue is. The Solis has the option to use a virtual or card SIM. I’m wondering if the router is trying to go through the virtual SIM settings? As I said earlier, I have the hotspot using a SIM card, but wonder if the router for some reason is grabbing the virtual card settings?

Update:
I switched the hotspot to use the virtual/eSIM card, and my speeds are great. So it’s definitely something to do with the physical card and the hotspot settings. Does anyone know how to configure the settings to use the proper SIM card?

Only one sim can work at a time right?

So when using the real SIM card, when connecting your phone directly to the hotspot it is fast, while using repeater with the router it is slow?

Pls double confirm that.

For the no internet problem can you make sure the repeater is connected?

I suspect that it is ttl settings.

Yes only one SIM card can be used at a time. So either the physical SIM card, or the eSIM card.

You are correct, when connected directly to the hotspot, and the hotspot is using the physical SIM card, my speeds are good. It’s when the hotspot is using the physical SIM card, and I connect to the hotspot with the router via repeater mode, that my speeds are slow.

I confirmed that the repeater is connected, I always have the admin page opened while testing the speeds via the SpeedTest app.

Thank you again for your help.

Let me know if you need anymore information. Or do you think I need to reach out to T-Mobile and see what settings the router should be using?

Update:
Quick question, could it be T-Mobile detecting the router and blocking, throttling, internet access because of the router? Just trying to think of any other possibilities.

I contacted the hotspot device company, Solis, and they confirmed that the settings for either the eSIM or physical SIM are the same. Not sure if this helps at all.

Here is a breakdown of all the scenarios as well:

Problem Connection Setup:

  1. Hotspot using T-Mobile physical SIM Card > Connected to Router with 5GHz Wi-fi > Router in Repeater mode > unusable download speeds of 3Mbps or less, upload speeds are anywhere from 1Mbps to 20Mbps
  • I get the same poor results if using 2.4GHz or 5GHz

No Problem Connection Setup:

  1. Hotspot using T-Mobile physical SIM Card > NO ROUTER > Connected directly to iPad and/or iPhone via 5GHz Wi-fi> Great speeds
  2. Hotspot using eSIM Card > Connected to Router with 5GHz Wi-fi > Router in Repeater mode > Great speeds
  3. Hotspot using eSIM Card > NO ROUTER > Connected directly to iPad and/or iPhone via 5GHz Wi-fi> Great speeds
  4. Home Network > Connected to Router with 5GHz Wi-fi > Router in Repeater mode > Great speeds
  • I get the same good results if using 2.4GHz or 5GHz

Can you try set up ttl for the repeater interface?

Try this in ssh of the router

iptables -t mangle -A POSTROUTING -o wlan-sta0 -j TTL --ttl-set 64

Thank you, the command is giving this error,
iptables v1.8.7 (legacy): unknown option “–ttl-set”

Sorry for this trouble taken. Please try these command one by one:

opkg update
opkg install iptables-mod-ipopt
iptables -t mangle -I POSTROUTING -o wlan-sta0 -j TTL --ttl-set 65

Then check if it works or not.