Slate AXT1800 and GoodCloud not unbinding

I had to reload my AXT1800 with a backup because it got hosed. Ever since then it showed as offline in GoodCloud. I removed it from GoodCloud and tried to unbind it in the Slate. The unbind says its success full, but it’s still showing up:

I tried disabling GoodCloud and re-enabling it, but the message still shows. Also, the device never connects to GoodCloud and I get the following in the log:

Fri Jun 23 09:09:31 2023 mqtt[19228]: main.c(1377)mqtt start!
Fri Jun 23 09:09:36 2023 daemon.err mqtt[19228]: url =
Fri Jun 23 09:09:36 2023 daemon.err mqtt[19228]: utils_NLB failed!

AdGuard was turned on and I tried the above steps with a custom rule that unblocked GoodCloud: @@||^

Same problem. Then I disabled AdGuard and I still have the same issue.

I have rebooted the router as well.

EDIT: I figured out the problem. It was TailScale. I disabled TailScale, registered the node with GoodCloud, then re-enabled TailScale.

You might want to edit the subject line to begin with [SOLVED] so others may know you found out a solution.

1 Like

I apparently do not have the ability to edit my post since it is over 24 hours old. Maybe a mod can edit the title?

1 Like

Humm… I wasn’t aware there was such a time limitation. I stand corrected. Yes, let’s ask if @alzhao can ‘do the honors.’

(It seems this forum software could use such a feature to mark such threads)

1 Like

Another thing, I have just disabled GoodCloud as I haven’t seen any added value for my one Slate. I could see the value if I had more than one in different locations that I had to manage remotely.

The biggest thing here is TailScale. I use it, a lot. So a word of warning for at least v4.2.1: Enabling TailScale breaks integration with GoodCloud.


Well said. Did you want to consider opening a ‘Bug Report’ post here for the firmware version & device you’re running & then link back to this thread for details? That might help bringing it to GL’s attention… & anyone else getting tripped up.

(I’m personally finding a lot of good tips, tricks and workarounds in these sub-forums but the ‘discoverability’/‘searchability’ to get them leaves much to be desired, IMO.)

1 Like

Good point. I’ll do just that!

TailScale and GoodCloud both enabled can work by disabling (not using) “Override local DNS” and “MagicDNS” in Tailscale Admin DNS.
This worked for me.

The problem with that is then DNS for my devices doesn’t work. I haven’t configured the Slate to do local DNS to off load some of the work. I’ll go in and see what the COU/Memory cost is for local DNS.