Slate Plus- 4.2.1 update broke AdGuard Home

AdGuard home no longer blocking ads. I had OISD full list but it seems it no longer works. I did reset the router but the problem persisted. It is stuck when I click enter and loading screen stays pretty much forever. Any solutions?

1 Like

could you please provide your OISD list? We will investigate the cause of this problem

it was not an issue of the blocklist. 4.2.1 update broke AdGuard for me at least. I installed the 4.2.0 version and everything is working again.

I have the same problem in a fresh install. I bought it this month and upgraded the firmware to 4.2.1.
I tried to add some list but every time the screen freezes.
This is the log I found

Tue Jul 11 10:49:56 2023 user.notice AdGuardHome[7280]: 2023/07/11 08:49:56.298845 [error] os.Chtimes(): chtimes /etc/AdGuardHome/data/filters/1689006883.txt: no such file or directory
Tue Jul 11 10:49:56 2023 user.notice AdGuardHome[7280]: 2023/07/11 08:49:56.299182 [error] POST 192.168.8.1:3000 /control/filtering/add_url: Couldn't fetch filter from url https://adguardteam.github.io/HostlistsRegistry/assets/filter_27.txt: scanning filter contents: context deadline exceeded (Client.Timeout or context cancellation while reading body)

I have the firmware to the 4.2.3 version and the problem is still there

Can you SSH into your Slate Plus (default IP 192.168.8.1) & confirm this directory is present?

ls -l /etc/AdGuardHome/data/filters/

See attached for help using SSH.

Yes I can confirm the folder is there. I was trying figure something out before and I did check there.
With some list did work but it wasn’t a smooth operation. I selected the list, the page frooze and then after a refresh of the page the list was added. Without the refresh the page remain freeze on the list selection.

Yeah, I imagine it wasn’t smooth. The other entry on that posted log snippet seems to indicate the http request timed out from pulling the list fr GitHub.

root@GL-AXT1800:~/tmp# wget https://guardteam.github.io/HostlistsRegistry/assets/filter_27.txt
--2023-07-14 17:55:15--  https://guardteam.github.io/HostlistsRegistry/assets/filter_27.txt
Resolving guardteam.github.io... 185.199.110.153, 185.199.111.153, 185.199.109.153, ...
Connecting to guardteam.github.io|185.199.110.153|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2023-07-14 17:55:15 ERROR 404: Not Found.

So some list “works” and some other don’t? Its a problem regarding Adguard or gl.inet?

It looks like AdGuard pulled down or change their entire source code repository, never mind the lists but provided no way for users to use the new URLs, not even a nonhelpful HTTP 301. That kind of thing is usually done on the server side to be oblivious to visitors/end users.

IDK from what sources you’re pulling all your lists.

I’m using the “choose from list” button. I’m not using custom lists.

Well, regardless the method the list feeds/sources are well out of date. I’d be very dismayed w/ AdGuard if they didn’t leave a HOW-TO on their site on how to update it.

Failing that there’s always

I updated AdGuard Home with success at the latest version.
I am still getting the same error, but maybe i found something.
I copied the POST request from the mozilla console

await fetch("http://192.168.8.1:3000/control/filtering/add_url", {
    "credentials": "include",
    "headers": {
        "User-Agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0",
        "Accept": "application/json, text/plain, */*",
        "Accept-Language": "en-US,en;q=0.5",
        "Content-Type": "application/json"
    },
    "referrer": "http://192.168.8.1:3000/",
    "body": "{\"url\":\"https://adguardteam.github.io/HostlistsRegistry/assets/filter_33.txt\",\"name\":\"Steven Black's List\",\"whitelist\":false}",
    "method": "POST",
    "mode": "cors"
});

In visual studio clicking the body link i am getting a 404 page of github but only for the “/” at the end of the url


But in the logs there is no “/”

Sat Jul 15 10:25:25 2023 user.notice AdGuardHome[10734]: 2023/07/15 08:25:25.544696 [error] POST 192.168.8.1:3000 /control/filtering/add_url: Couldn't fetch filter from URL "https://adguardteam.github.io/HostlistsRegistry/assets/filter_33.txt": scanning filter contents: context deadline exceeded (Client.Timeout or context cancellation while reading body)

I tried also leave the request go on and i find this error in the networking part of mozilla debug tools
NS_ERROR_NET_RESET

I also get output when using curl, no trailing slash. Note \" is used to escape the quotation mark in Linux/shell scripts so they’re outputted properly "like this" but it still doesn’t explain why curl can pull the list:

root@GL-AXT1800:~/tmp# curl https://adguardteam.github.io/HostlistsRegistry/assets/filter_33.txt
!
! Title: Steven Black's List
! Description: Unified hosts file (adware + malware).
! Homepage: https://github.com/StevenBlack/hosts
! Last modified: 2023-07-15T03:17:49.149Z
!
! Compiled by @adguard/hostlist-compiler v1.0.22
!
!
! Source name: Steven Black's List
! Source: https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts
!
# Title: Hosts contributed by Steven Black
# http://stevenblack.com

0.0.0.0 ck.getcookiestxt.com
0.0.0.0 eu1.clevertap-prod.com
0.0.0.0 wizhumpgyros.com
0.0.0.0 coccyxwickimp.com
0.0.0.0 webmail-who-int.000webhostapp.com
[...]

I’m pretty sure it’s not suppose to be this difficult. It looks like you’ve found a bug to report to AdGuard.

1 Like

Yes same thought here.
Thanks for the support i will open a bug on their github.
Have a nice day :slight_smile:

1 Like

same issue here… with the adguard version delivered with 4.2.3 and also with an updated one.
only the two default lists are working. adding additional lists is not working.

Guys have you found a solution? I have this issue still and it’s annoying as hell. What can be done?