SlateAX + AdGuard Home in Docker, clients show, but DNS doesnt work

Am I crazy but shouldnt my DNS server be when I do a NSlookup?
I’m trying to point my DNS to my Adguard Home(AGH) Docker container and see clients in AGH.

It’s like Openwrt doesn’t honor the DNS settings. It should provide to my clients.

I renewed my network config in Windows.


Non-authoritative answer:

I have set on my SlateAX DNS settings.

I cant get the TopClients to show my devices, only the GL.inet router.

I’ve adeed the redirect in Firewall forward, but when I do this, my DNS completely dies.

but I do see clients in AGH now. But DNS completely dies. Without the port forwarding, my DNS works.

My AGH settings are the same, before and after port forwarding

If you run the ipconfig/all in a Windows command prompt, does it show the DNS server as the Slate AX IP address If so, then the DNS request is first sent to the router, which then forwards it to the AdGuard Home IP address Hence, AdGuard Home would think the request is from the router.

In this situation, you can set the DHCP server to give out as the DNS server to the clients. so DNS requests go directly to AdGuard Home.

I do not work for and I do not have formal association with GL.iNet

I did try that once. I will try it again. Thank you.

Pls add 2 DNS servers.

I agree that you should set up at least 2 Upstream DNS servers in AdGuard Home, which could be CloudFlare.'s primary DNS and secondary DNS On my AdGuard Home, I use DNS over HTTPS.

I also set up 2 separate AdGuard Home servers, in case one goes down due to problems or for maintenance. My primary AdGuard Home server runs in Docker on Synology NAS that is very reliable and my secondary AdGuard Home server runs on a standalone GL-MV1000W BrumeW that is connected via Ethernet LAN port only, without any WAN.

All I had to do to was to set up the DHCP server on my main router give out the 2 IP addresses as the DNS servers to clients. On GL.iNet/OpenWRT routers, you have to do that with a DHCP Option via LuCI → Network → Interfaces → LAN → Edit → DHCP Server → Advanced Settings → DHCP-Options.

Can I defined my in this field instead?

I believe that would be the DNS server for the Slate AX router (LAN interface) itself, not given out to client devices. To check, you can run the ipconfig/all in a Windows command prompt on a client device to show it DNS Servers.

The DHCP Option can be entered in the DHCP Server tab.

Will do. I will never understand the devs behind openwrt, they think backwards.

so going that route, it did give my device a address. I guess I will need to reboot each device so it can get a new DNS config. sigh.

   Subnet Mask . . . . . . . . . . . :
   Lease Obtained. . . . . . . . . . : Monday, August 29, 2022 3:30:43 AM
   Lease Expires . . . . . . . . . . : Tuesday, August 30, 2022 5:01:16 AM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :

Gl.inet should hire you. you help alot.

Try just rebooting the Slate AX because it may clear the DHCP leases.