Slow connection of Mifi 4G T-Mobile USA via Wifi

I have Mifi with EC25-A. The 4G LTE sim card is from a working phone. 3G connection is fine. When I tested the speed by SSH into the MIFi and using wget to test,

wget -O /dev/null

I got about 500KB/s download.

When I connect to Mifi from Wifi and test download the same .zip file, I only get 65KB/s. The speed is always about 60KB/s no matter where I test it.

At the same location, I use another phone with tethering from the same laptop to test the speed, I got about 4Mb/s, which matches the raw test speed using wget from the SSH in Mifi

Please advise what the issue could be?

More info: when I tested at another place, the internal wget posted 1MB/s speed, when I connected to Mifi LAN port directly, I only got about 60KB/s (the same slow speed as if when I connected to Mifi via Wifi).

Please advise.

I figured it out. The issue was not in the Mifi. It was my data plan. The t-mobile one plan I have, limits 512Kb/s for tethering. I guess that’s probably the reason.

The partial solution is to change my windows 10 TTL to 65, so as to make the traffic TTL 64 when it goes out from Mifi. Thus it can by-pass the tethering check/restriction.

I like to know how I can set up a firewall or routing rule in Mifi/Openwrt, to change the TTL of all traffic from LAN side (wifi, or ethernet lan port) to 64 before forwarding to the 3G/4G.



I am very interested to read your experience, especially your work-around re. tethering. Where did you discover this fix and what are you doing exactly?

Interesting. Not too much idea now but will pay attention to.

This is how I fix it.

In Network–>Firewall–Custom Rules,

Add the line: iptables -t mangle -I POSTROUTING -o 3g-modem -j TTL --ttl-set 64

It shall look like


iptables -t mangle -I POSTROUTING -o 3g-modem -j TTL --ttl-set 64

force_dns() {

lanip=$(ifconfig br-lan |sed -n ‘s/.dr:(.) Bc.*/\1/p’)

iptables -t nat -A PREROUTING -s 0/0 -p udp --dport 53 -j DNAT --to $lanip

iptables -t nat -A PREROUTING -s 0/0 -p tcp --dport 53 -j DNAT --to $lanip


force=$(uci get glconfig.general.force_dns)

if [ -n “$force” ]; then




This shall overrides the ttl of traffic going out through 3g-modem to 64. It makes the carrier (t-mobile for this case) ‘think’ the traffic is from the phone (sim card) itself (as traffic from Android and iPhone has ttl of 64), instead of tethering traffic (Windows etc.)

Hope this can help people in USA.


Thanks for sharing.

@KUN, this is very helpful. Very good hack.

@KUN, I wonder if you have tested ATT 4G speed on MiFi?

I’ve been testing the speed on AT&T. I have three hotspots, a Unite Explore, a Netgear Nighthawk M1, and the Gl.iNet MiFi. These all have their own SIM, post pay AT&T, Unlimited Plus plan, stream saver turned off. All SIMS have their own 22GB allotment. The Mifi is not under deprioritization. The Unite Explore has 55Gb used with 15 days left, the Nighthawk has 155Gb with 15 days left, and I’d have to log into the AT&T backroom to tell you what the Mifi is, but I haven’t been using it as much, so I doubt it’s too much over 10Gb. I could be wrong, I’ll check later. So the two Netgears are falling under deprioritization on this tower, but it’s hardly ever congested. You can’t tell if/when it is.

The Mimo antenna has made things faster before, but today we are having a small snowstorm. About 3 inches, and it’s coming down at a decent rate. I’m less than a mile from the tower, and it’s usually 700mhz or 1900mhz. Both seem to go through the trees just fine.

Test One – Unite Explore USB Tether into AR300M


Test Two – Unite Explore USB Tether into AR300M


Test Three – Unite Explore, Unite Explore USB Tether into AR300M with Mimo antenna


Test One – Nighthawk M1, over ethernet WAN into AR300M, No MIMO ext antenna


Test Two – Nighthawk M1, over ethernet WAN into AR300M, No MIMO ext antenna


Test Three – Nighthawk M1, over ethernet WAN into AR300M, No MIMO ext antenna


Test One – MiFi over ethernet Wan into AR300M, external 5dbi oar antenna Only one, lead was too short for other sma adapter, longer cable on the way for diversity antenna. Right now internal LTE antenna is hooked to diversity. Not sure what the impact of that is, but with only an internal antenna, and no diversity plugged in, the speed tests are similar. I think they were more 9Mbs to 13Mbs down, and the same for uploads. So I think the antenna is a weak spot for the MiFi. I have no idea why the uploads are consistently higher than the downloads since the antenna swap.


Test Two – MiFi over ethernet Wan into AR300M, external 5dbi oar antenna


Test Three – MiFi over ethernet Wan into AR300M, external 5dbi oar antenna



All of these tests for all hotspots were run in the order posted, in about 30~45 minutes, mid afternoon on a Saturday, in a slight snowstorm, all next to the same window towards the same tower. The MiFi seems to hamstring the AR300M’s throughput if I put the Mifi in with one of the other hotspots for load balancing. 4G LTE is also very volatile, so it’s difficult to get consistent charts. So I didn’t do but a few tests with the Mifi load balanced, and I didn’t save that information. I plan on revisiting it with the second antenna soon.

I also got load balancing to work on the AR300M.

The bufferbloat is bad. It’s not the router, I have the hotspots on passthrough now, and even when plugged into the PC directly, the bufferbloat was bad. The MiFi is not feeding the GL-AR300M with the load balancing. It’s the two Netgears, both with IP passthrough. There’s no bridging option. I also turned off DHCP in both.



And 5 minutes later, this:



It’s really all over the map sometimes. That’s 4G for you.

This is over Cat 5, everything else is over Wifi configured to 802.11N, not G.


The MiFi is using external 5dbi oar antenna for 4G, right? The speed is not that high.

What about the performance of the Internet Antenna?

The internal antenna is barely worse. I don’t think it’s the Mifi, though. I think it’s the modem.

I bought this:

It came in today, so I fooled around with the LTE modem.

I pulled the EC25-A out of the Mifi, and put it in that USB adapter with the same SIM (had to use a SIM adapter, it wants a full size SIM, so I had to fiddle with it), but after that it worked fine. Windows drivers are in this package (warning, large file).

After it was installed, I ran the same speed tests. Not really any difference from the Mifi. Now, I don’t know what the gain is for the antennas that came with that adapter…or if those antennas even do 700Mhz. For all I know they are Wifi antennas. The kit came with RP-SMA connections, and my 5dbi oar antennas are SMA, so I couldn’t swap them out. I’m not convinced it would make that much of a difference, though.

So, right now, to me, either AT&T is throttling the EC-25A (and other non-ATT modems), or there is a driver issue that is present in Linux and Windows, or there is a default configuration with the drivers that’s limiting performance.

I have hit 30mbps upload and download a few times with the EC-25A. But it’s only happened about half a dozen times total. One of those was today in Windows connected to a VyprVPN server. I couldn’t recreate it. Most of the tests settle around +/- 15mbps down and +/-10mbps up, regardless of being in the Mifi, or in this adapter, or connected to a VPN. There are spikes into the high 20s on both up and down connections, but it’s rare.

So, from the looks of it, the Mifi’s board isn’t the bottleneck. I also don’t believe the internal antenna is limiting the performance that much. The oar antennas are maybe 10% faster on average, and they are cumbersome.

I think something else is going on with the EC-25A specifically. I hope it’s a configuration issue so we can open it up.

As an update, these Mifi benchmarks were with USBTTY* configured, not QMI. For whatever reason, QMI was not loading and I had no ability to enable QMI until the last official firmware update. Perhaps it just needed a factory reset, I’m not sure. I’m using the

With QMI configured, with the same setup, the MIFI is as fast as the other two at this location, on both Tmobile and AT&T. I have gotten 50Mb down late at night when the tower was unpopulated.

The fact that the speeds weren’t any faster with Windows points to a USB setting being the limit, I think. I haven’t tried it again in Windows to confirm.

Still think the biggest problem is the antenna. Your external antenna may not have high gain as well.

MiFi could achieve 60Mbps download speed with good external antenna.

My signal strength is usually 28~31, 99 on the MIFI with the Proxicast antennas.

I’ve only seen 70Mbs from this tower as of this morning, and that was on the phone. When I run concurrent speed tests, I never get more than 70Mbs aggregate, up or down.

I also can’t get much closer to the tower. I’m literally 1km on Google Maps, straight line. In fact, if I get closer to the tower, speeds are reduced from ground interference, by half.

Which may be more of the issue. Best I can tell, my tower doesn’t do aggregation, otherwise the Netgears should have much higher speeds.

I used to get B17, not it’s all B2. I don’t have Rooter Firmware installed, so I don’t think there’s a way to lock the bands for further testing.


^Internal antenna right now


^External Omni Antennas. Strange, considering the lower signal strength.


^Sierra Wireless Antennas



These are back to back right this very moment. I have two MIFIs with ATT SIMs in them.

I reran the internal antenna speed test a few more times. The upload bandwidth increased, but the downloads don’t like going past 30Mbs down. This is as fast as I’ve seen it with internal antennas here. Same signal strength as the first time.

I don’t think it’s too shabby considering this is what my Nighthawk gets (below)…now, this is deprioritized, it’s way past 22Gb this billing cycle, unlike the other two SIMs.

As you can see, nothing gets 60Mbs down out here, especially in the middle of the afternoon.