Slow Wireguard Speeds GL-MT1300 (Beryl)

I need some help to figure out and improve Wireguard speeds. I have 2 GL-MT1300 (Beryl) units, 1 serving as Wireguard VPN Server at home and 2nd unit serving as mobile VPN Wireguard client (mainly at vacation home). I have 100 MBPS up and down at both locations. I’m only getting 2 MBPS up and down over VPN.

Following is output of trace rt from client to server (glddns).

1 4 ms 2 ms 1 ms []
2 65 ms 59 ms 56 ms
3 191 ms 131 ms 66 ms []

I had these configured as OpenVPN and I was getting much better, 8Mbps up and 5Mbps down, but not good enough for video call.

I primarily use work laptop which has corporate Cisco AnyConnect. When connected using Openvpn, everything works. When connected using Wireguard, Outlook doesn’t work. I suspect my Wireguard handshake is not proper/optimized and as such Cisco Anyconnect Tunnel has issues working within Wireguard tunnel. Or, there’s leakage.

I’m not very savvy with this. Please advise how can i troubleshoot or which commands I can run.


You can try VPNPOLICY and add Cisco Anyconnect subnet to the exception list

What upload and download speeds do you get when connected through WireGuard, but without going through Cisco AnyConnect?

Did you previously use OpenVPN over TCP or UDP?

I do not work for and I am not directly associated with GL.iNet

That will defeat the purpose. I want Cisco Traffic to go through Wireguard VPN.

OpenVPN was on UDP. Is TCP faster than UDP?

Without Cisco Anyconnect, I get awesome speeds on WIreguard. 50 Mbps Download and 50 Mbps Upload at-least if I recall.

On your client/remote wireguard router, try setting the Wireguard MTU to 1280. Having some pages not work is a possible symptom of packets getting fragmented.

you can set the MTU of wireguard directly in the vpn dashboard.

If you had previously used OpenVPN over TCP, then I would have suggested to try UDP to better speed for video calls because UDP is usually a little faster.

As Eric suggested, setting WireGuard MTU to 1280 is a good idea.