SMS Forward Doesn't Show Original Sender’s Number


Silly question.

The forwarded SMS shows the forwarding number instead of original sender’s number.

Is that how is supposed to work?


Do you mean on the router’s UI?

Yes, on the router UI.

Yes it is normal. The current UI does not show the SIM own number.

We are improving this in firmware 4.3.

Hi alzhao,

I meant that the forwarding is done on the router UI.

No sure what you mean by “The current UI does not show the SIM own number.”

My question is about the forwarded SMS. It shows as coming from the forwarding number and not form the original source.

This makes the feature unusable as you cannot tell who sent the SMS.

something like this: Mudi SMS forwarded → VOIP SMS.
Looking at VOIP SMS all messages are coming from Mudi SMS

I see. If you forward via sms, the router just forward the orignal message from the router. So there is no info about the original send.

Can you forward using email?


Email forwarding works.

So, what is point of SMS forwarding if they all end up showing like they were send by the Forwarding number?

Thank you!

1 Like

That is a good question. But I think it does needs to show the number which forwarded the sms.

Maybe like emails, modify the content like
[original nubmer]send you a message: [message details]

Not sure what you mean by
" like emails, modify the content like
[original nubmer]send you a message: [message details]"

as for email forwarding, I only have the option to set the subject on the router GUI, which is added in front of the subject that the forwarder has by default.

like this:

Subject: Test

Emali subject Test received a message from [original sender number / name]

So, if you can point me in the right direction where I can find more information about SMS forwarding customization it will much appreciated.

Thank you.

I don’t have this info unfortuantely.

Now sms is generally for code verification so the message body saids everything. The sender numbr even does not matter.