Solution for broken mDNS on Brume 2 (GL-MT2500/A)

After commissioning a Brume 2, my *.local name resolution no longer returned any IP addresses.

Apparently support for this is provided by mDNS, aka RendezVous / Bonjour / ZeroConf.

I am posting this because I couldn't find an answer in the forum, and others may benefit from what worked for me.

As nothing else had changed on my network, I checked the config of my old router, which was also OpenWrt-based.

Both systems had these packages:

  • avahi-dbus-daemon
  • libavahi-client
  • libavahi-dbus-support

In my case, I had to add the umdns (OpenWrt Multicast DNS Daemon) plug-in, which was present in my old router, but not in the Brume 2.

After that, name resolution immediately performed as expected.

I cannot say if any other mDNS daemon would also work - I simply haven't checked.

1 Like

Where is your *.local domain name set?

Is Brume 2 under your DHCP server or above?

In Brume 2, network->dns pls find "DNS rebind Protection" and disable this one. Generally this is where the local domain name blocked.

Thanks for taking an interest.

I have not explicitly 'set' *.local. My understanding is that it is created dynamically by mDNS.

My Brume 2 is the DHCP server for my network. It routes between my ISPs modem/router, and my Wifi network (an eero hub interconnected with another 3 such nodes - eero operates only at layer 2). I use it only for:

  • routing / DHCP
  • basic firewall, with 80/443 forwarded to an internal NGINX reverse proxy
  • DNS with AdguardHome
  • ddns-scripts (to namecheap)

I will also implement a wireguard-based VPN sometime in the future.

Yes, I had tried this - it did not solve my problem. After I implemented the solution described above, I have re-enabled it, and that has caused no problem..

Other useful commands:

Verify the install of umdns worked and it is up:

# ubus call umdns hosts

You can also try the following if the router is not resolving in .local yet:

# ubus call umdns update

wait a second or two, then

# ubus call umdns browse