[SOLVED] Cannot Access Beryl AX Webadmin using IP Address assigned by another Router?

I did a search on the forum and in the FAQs, but I cannot find any details on this issue.

The Beryl Network Mode is “Router”. In that mode, the problem is this:

I cannot access the Beryl AX (MT3000) webadmin using the IP Address assigned to it by another Router (An ASUS RT-AX86U).

This is the same for both IP Addresses ( and , one for an Ethernet connection and one for a Wifi Connection to that Router. The Browser just does says “This site can’t be reached took too long to respond”.

I can access devices on other IP addresses assigned by the Asus Router, both via WebAdmins and via SSH/WinSCP. Without this access I cannot use WinSCP.

Now, I can access the Beryl’s WebAdmin and SSH (using an iOS Terminal App) into it from an iPAD connected to the Wifi of the Beryl AX using the Beryl’s address When I look at the “Network” tab of the GLiNET App, I can see it is assigned an IP Address 192.168.9. 222 (or 223), which is the same address in the ASUS Webadmin. I tried it with the repeater off and again with it on. I tried using from the Windows Browser. No go there either.

Can anyone shed some light as to why I cannot access the Beryl using the Address assigned by my main router?


[EDIT] Solved! It works when the Beryl is in “Access Point” Mode, but not when it is in “Router” Mode.


In router mode you have a WAN side (internet facing) and a LAN side (internal network), with a firewall between them. You are describing a problem accessing the webui from the WAN side. This is by design. Allowing the router itself to be accessed from the internet presents a security issue.

When the Beryl is behind another router that issue is mitigated by the other router’s firewall but it is still a step not to be taken lightly.

1 Like

Great explanation thank you very much; it definitely makes sense from a security standpoint!
Was just a bit frustrated as I was more comfortable using WinSCP (from my PC) in order to modify /etc/config/wireless, than to issue commands via a terminal on my iPAD connected directly to the Beryl’s Wireless. I guess I could add a Wireless Dongle to my PC though and connect using the PC. Next time :-).