SOLVED - GL-AR300M-Lite trouble upgrading

I have a GL-AR300M-Lite and I can not get it to upgrade to . It is currently at 3.216. I updated the U-Boot.

I am trying to use “Stable” files under the AR300M Shadow download area. I confirmed all checksums of the files downloaded - so it is not bad downloads. I tried both the web admin and the U-boot .img file updates. The web way seems to hang with the gui saying “Uploading” and the version information never populating and it shows “Verifying…”. I have let it run like that for more than an hour and still nothing.

When doing the U-boot method - I get to the and it goes to the “Update in Progress” screen (I don’t recall exactly what it says). After a bit of blinking and all it eventually went to 1 red light. I tried reaching the router or searching for the wifi but nothing. The screen says that the router will automatically reset. So after 30 mins of 1 red light on the router, I rebooted the router. Nothing updated.

Should I be using AR300M16 Shadow files? I know I have a lite - but can’t confirm if that equals 16 today?

I am on a Linux laptop and tried both Firefox and Chromium but no change. I believe the Uboot updated - the lights that blink and pattern when holding the reset button seems different.

What else should I try?

Thanks in advance!!

Never mind. Apparently the AR300M-lite as it says on the shell is actually the AR300M16.

Downloaded the file for that router and flashed with the U-boot method and all is good now.


1 Like

Great @VoidnWarranties , thanks for sharing your fix!