[SOLVED] Mango worked once, power led blinking indefinitely after update

GL-MT300N-V2 Mango

The router worked once, but since I did a firmware update from the admin panel it wont work at all.
I tried the firmware update through Uboot (Debrick via Uboot - GL.iNet Docs) and the result is the same.

After firmware update, it’s stuck on the power led flashing white indefinitely, router cant be reached, and wireless led stay off.

I’ve seen other people, in the forum, with a similar problem of the power LED blinking, but with no solutions.

Small update: When flashing clean version of firmware, the power led stay solid white, router can be reached trought ethernet and wireless can be activated using OpenWRT admin panel.

But, after trying to flash a stable version from the OpenWRT admin panel, router return “503 - Service Not Available”

Can you let me know which “stable” version did you use?

503 seems that configuration has problems. This usually due to upgrading with settings kept.

I first flashed the clean image (gl-mt300n-v2-3.0-1011_clean.bin) and then, from the LuCi panel, I updated the firmware using this stable image: openwrt-mt300n-v2-3.211-1227.bin

I also tried with the latest openWRT image (Index of /releases/21.02.3/targets/ramips/mt76x8/ > glinet_gl-mt300n-v2-squashfs-sysupgrade.bin) and it worked, but it doesn’t solve the initial problem since I lose the benefits of GL.iNet administration :slightly_frowning_face: (this was the main reason I bought it instead of using a raspberry pi with openWRT)

I tried with 3 different power sources, laptop usb, phone charger and 5V/1A powerbank.

I think the problem is solved: it seems to be the power sources that is at fault.
I redid the uboot flashing (openwrt-mt300n-v2-3.211-1227.bin) with a different power source and everything was fine.

Apparently the USB 2.0 port on a mid-2012 macbook pro only delivers 500mA. :woman_shrugging:
The powerbank I used delivers 5V/1A but maybe that’s not enough or stable for the router? :thinking:

After trying different phone chargers, I found one (5V/1A output) that satisfies the mango.

In conclusion:

  • I guess a flashing power light means there is a power problem…
  • And if you encounter the same problem, try different power sources even if they provide 5V/1A as required.
1 Like