[SOLVED: Queued Bug for Fix] GL-MiFi EC25-AF Verizon SIM Intermittent "SIM card is not registered"

All -

I have a Verizon Postpaid account.

I took a pre-activated SIM card and popped it into the GL-MiFi EC25-AF modem (which covers several Verizon bands). The SIM had already been activated in another device so it worked.

I am having intermittent success accessing the internet but occasionally instead of showing the signal strength, I’m seeing a “SIM card not registered” message displayed. Sometimes it goes away and I am usually able to access the internet while I see the message; however, occasionally the internet does not work.

I’m wondering if you have any tips on fixing this.

Regards,

Michael

When this happens, can you ssh to the router (or use luci) to get the log?

logread
dmesg

Yes. What specifically are you looking for in the logs or do you want me to private message the to you?

if you can send the full log that will be better. I am not sure if the log can tell anything.

If necessary need to issue some AT command. But pls send the log first.

Hi,mbw

When that happens, you can use AT+CREG? And AT+QNWINFO query network registration information

thanks

AT+CREG = "OK"

AT+QNWINFO

+QNWINFO: "FDD LTE","311480","LTE BAND 4",2125

OK

Notice the "? "after the command.the command is AT+CREG?

My fault:

+CREG: 0,3

OK

I should add that the internet is generally working even when the " SIM card not registered" is displayed and AT+CREG? displays +CREG: 0,3. Seeing speeds of about 10-15Mbps Down and 5-10Mbps up.

According to modem’s manual, this result indicates that the registration was rejected

Weird. The Internet seems to be working 95% of the time even when this is happening.

The correct IMEI is also showing up on my Verizon account (it matches the modem IMEI for registered device).

I need to get some information from QUECTEL first

Sounds good. Some other output in case you need it.

+COPS: 0,0,"Verizon Wireless",7

OK

+CSQ: 29,99

OK

Could you help check AT+CEREG? and the AT + CGREG? ?

+CEREG: 0,1

OK

+CGREG: 0,1

OK

Thanks,

I asked FAE of QUECTEL, his feedback is whether the module needs to register the network according to AT+CREG?, AT+CGREG? and the AT+CEREG?
I just judged AT+CREG?, Therefore, this is a BUG in the code

Thank you. Do you need me to submit a bug report or will you add one to the queue?

Regards,

Michael

You can submit it to the BUG list, and I’ll fix it.

Bug https://bugs.gl-inet.com/view.php?id=215 has been submitted for tracking this issue.

Regards,

Michael