[SOLVED (so far)] AR750S Cannot See Any SSID


#1

Just got my AR750S over the weekend. Yesterday it was working perfectly. I was able to connect to my cellular hotspot over wifi and share to multiple laptops. I unplugged it at the end of the workday and brought it home. I then turned it back on at home and successfully connected to my home wifi router.

This morning I started up my cellular hotspot, plugged in the router, gave it a couple of minutes, then tried connecting with one of the laptops I was using yesterday. I can connect to the interface, but the AR750S can’t see my hotspot anymore. In fact, it can’t see ANY SSID.

I tried the 3 second reset. I tried the 10 second reset. I tried installing the 3.003 firmware back to the AR750S via the web interface.

Nothing is working. The radios clearly work, as I can connect over wifi to the interface, but I cannot get it to find ANY SSID on a scan.


#2

Ok. Got it working. I noticed that there were no plugins listed. I manually downgraded to 3.002 via the admin page. The router came back up fully functional. I then did the online upgrade back to 3.003. Again, the router came back up fully functional. It’s still working right now. If the problem recurs, I’ll post again.


#3

The " cannot see any ssid" problem is actually due to there is a very long ssid nearby. We fixed it in v3.003

Not sure why you had this problem.