Specific website won't load when connected via GL-iNet router

Posting on behalf of someone here.

Someone is trying to connect to whos-next.com. They are running a Tailscale exit node back at home. The Beryl AX is configured with Tailscale enabled and DNS set to auto in the router admin page.

Connecting via two different laptops (and different browsers, cache cleared) and an iPhone does NOT work when connecting through the router, however connecting using a Tailscale client on the device (ex. iPhone Tailscale app), the website will load fine.

The weird thing is I tested the website myself on my Beryl AX and exit node and the website loads fine. I’m stumped on what else to try to diagnose this issue.

By the way, don’t suggest any diagnosis involving pinging that website because whos-next.com blocks ICMP requests/replies.

Edit: I’m suspecting the Azure DNS of this website has something to do with it.

Do you enable VPN policy and adguardhome? please try to turn it off.
When using tailsale exit node, it’s also a kind of VPN client, but the policy and DNS part are fully covered.

No additional services are enabled. Only Tailscale.

Have also tried manual DNS with Google servers and no luck with that particular website.

I guess the path to that site is through the relay. So the traffic or ttl is limited, you can capture traffic on the home tailscale node to see what happened.

Nope, not relay. Checked with “tailscale status” and the GL iNet router showed direct connection. Also, the TTL for that website is 1 hour.

Could you please try to do a traceroute to this website while connected?

Could you elaborate what you’re looking for in the traceroute? I assume you mean while connected to the website via Tailscale client.

Exactly. I want to know there the connection drops - since this is what traceroute will show.

The connection doesn’t drop when connected to the Tailscale client. It drops when connected through the GL-iNet router (which is connected to exit node as well).

So you can simply do 2 traceroutes so we can see if the connection really drops at the router or if there are other issues. Traceroute is just a pretty basic troubleshooting tool.

Do you mind posting a traceroute to whos-next.com as an example (obviously blocking out your own IP)? For comparison. In the meantime, I’ll try to get some results on my end.

The website loads fine for me but the tracert is struggling.

C:\Users\doczenith1>tracert whos-next.com

Tracing route to whos-next.com []
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  RT-AX88U_Pro-EE80 []
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4    21 ms     9 ms     8 ms
  5    16 ms     9 ms     9 ms
  6    11 ms    15 ms    45 ms  ae86-0.chg-96e-1.ntwk.msn.net []
  7     *        *        *     Request timed out.
  8    23 ms    16 ms     *     be-120-0.ibr02.ch2.ntwk.msn.net []
  9    18 ms    16 ms     *     be-6-0.ibr02.dsm05.ntwk.msn.net []
 10    27 ms    16 ms    19 ms  ae162-0.icr02.dsm05.ntwk.msn.net []
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15     *        *        *     Request timed out.
 16     *        *        *     Request timed out.
 17     *        *        *     Request timed out.
 18     *        *        *     Request timed out.
 19     *        *        *     Request timed out.
 20     *        *        *     Request timed out.
 21     *        *        *     Request timed out.
 22     *        *        *     Request timed out.
 23     *        *        *     Request timed out.
 24     *        *        *     Request timed out.
 25     *        *        *     Request timed out.
 26     *        *        *     Request timed out.
 27     *        *        *     Request timed out.
 28     *        *        *     Request timed out.
 29     *        *        *     Request timed out.
 30     *        *        *     Request timed out.

Trace complete.

The website loads fine for me but the tracert is struggling.

That could be because it’s trying to use ICMP, which this particular website blocks. So what’s happening is the IP packet gets to the Microsoft Azure router and “probably” reaches the host, but it just doesn’t respond. Same thing happens for me.

Issue solved. Manually used “https://” to access website. Seems redirect is broken on user’s end for some reason.


Could be a privacy feature as well. Some browsers and plugins block plain HTTP.