Spitz AX failing to provide internet despite proper sim registration on network

I have a new Spitz AX, the 5G model. It’s given me a lot of trouble, so this is going to be a very long post, but I hope that in providing all the information I can I’ll be able to get some assistance in making this thing not be a brick anymore.

The Setup

  • Spitz Ax + IMEI alteration + phone sim (don’t judge; there are literally no ISPs serving my area for home internet)
  • TP-Link Archer C20 in Access Point mode connected via ethernet to Spitz for the device that can’t see Spitz’s wifi

Initial Issues

  • Invisible Wifi: One device absolutely could not see the 2.4Ghz channel from Spitz AX. It’s a b/g/n laptop, rather old but has never had problems seeing networks on other routers once b/g/n mode was enabled. Except now. I bypassed that issue after trying every imagineable settings change by just using an access point.
  • Wifi Connection Issue: Devices that were capable of connecting to the Spitz’s Wifi networks would initially get “connected, cannot provide internet” or whatever the wording (it varied by device). I would have to forget the network, log in again, forget the network, toggle wifi, log in again, forget it again, etc. - up to a dozen times before finally it would connect and be allowed internet access.

Initial Troubleshooting

  • Upgrade Firmware: Per suggestions I got on Facebook from others who said they had flaky WIfi initially, I upgraded the firmware. At first, I got a weird error, I don’t remember what it said but think it mentioned not having permission…? Not sure. Anyway, I rebooted and when I got the prompt to upgrade firmware I told it yes and it worked. I thought.

Worse Problems

  • Unreliable Internet: My connection had been great on the devices I managed to connect, and had been working perfectly for hours. After the firmware upgrade, it was extremely unreliable. I also found that one device was unable to reconnect after it had been in airplane mode. Same connection issue as before, except worse - it couldn’t get internet no matter what.

More Troubleshooting

  • Reset, Reset, Reset: So. Many. Factory. Resets. Some of them changing only one or two settings such as the wifi networks and passwords. Some of them changing literally nothing. Some changing the APN to the one that works better. Some not changing anything and leaving Auto Setup to do its thing.
  • Another Upgrade: In case something went wrong the first time, this time I went to the GL.iNet website and downloaded the latest firmware for the Spitz AX. I installed it. I did another factory reset. Nothing changed.

Current Issues

  • No Internet: I have the sim inserted. I have power cycled dozens of times, factory reset etc. as outlined above. It just plain will not allow internet connectivity to any devices, whether connected to the access point or connected to the Spitz’s wifi. The sim registers on the network, has excellent signal, is connected in every possible way I can find, and can even send text messages but not receive them. But no devices can access the internet.
  • Weird Error: Occasionally, I get an error on the top of the GUI for the Spitz AX that says something about an ‘unexpected error’ and prompts me to check the network or reboot. The cellular network says it’s connected and reboots don’t fix anything.
  • DHCP Issue: The access point keeps showing, in the client list, as having the same IP address as the one device connected through it. This is despite having given the access point its own IP and power cycling it. Sometimes it starts showing the right IP, but then it cycles back to the wrong one.
  • DNS Issue: Not sure if just a generic error, but when I try to access sites while connected to the cell network via the Spitz, it says the DNS server can’t be found. This is true even when I change to any of the built-in DNS options (Google, Cloudfar, OpenDNS, etc.) and the DNS servers for the carrier are not down because when the sim gets put into a phone it works perfectly with no alterations.

Please, help. This stuff is far over my head and I’ve done everything I can think of with no results. My Spitz AX has basically become a brick, and I don’t understand why or how because I can’t find anything that seems out of the ordinary. I only found one thread, which seemed to be for a non-AX Spitz, and the solution to their problem isn’t the solution to mine; they had a misconfigured guest network, but I’ve currently got just factory default networks and no enabled guests. (Also, the error happens on the Access Point too.)

I had the same issue at first using T-Mobile Sim card and after a firmware update and manually changing TTL to 64, the unit is working fine.

Re: Invisible WiFi

I’ve ran into this before with older devices and an AX class router. My solution was to disable AX on the 2.4 GHz radio.

If there is no problem with the network, this is usually caused by some service in the background not running as expected.
If it occurs frequently, can you look at which services are getting errors when their interfaces are called? (Open the console by pressing Ctrl+Shift+I in your browser and click on the Network tab to see)

Thanks for the replies!

Good news where it exists: I figured out why I couldn’t connect through the AP. I kept overthinking the DHCP issues, and finally poked at the AP a lot. It was set to have DHCP disabled, but on a hunch I went ahead and factory reset it and set it back up as an AP. After that, the DHCP issues disappeared so I assume the toggle to disable it wasn’t really working and my laptop was stuck in limbo.

Bad news: I’ve still got problems.

I’m on AT&T which isn’t supposed to need a TTL change, and I had it working without before. But I appreciate the suggestion! I’m not sure if the TTL alteration fixed it or the AP reset did, but I’m able to get my devices online now so that’s good. I do get a split second of “no internet” when connecting to the wifi, but then it sorts itself out.

Sadly, I tried that (running in b/g/n mode), but the laptop still refuses to see the network. Maybe it’s just so old it can’t handle even that…? I’ve had this thing since 2015 I think. Need a new one, but money’s tight after the Spitz AX purchase. :laughing:

I sat there staring at it for a long while, but the message hasn’t popped up again. I wonder if maybe it was related to the DHCP issue. Uncertain.

While I’ve got internet running now, though, I’ve encountered some more strange issues related to the connectivity in the Spitz. Namely: upload speeds are abysmal and inconsistent, see-sawing back and forth between good and awful and downloads will finish, restart, finish, restart, then error out with “Failed - Network error” in Chrome on my laptop or get all the way to the end then say “Download failed” in Opera GX on my phone. I had this problem when I first set up the Spitz and a change of APN fixed it… but the APN I’m using now is the one that had fixed it before all the factory resets etc. So I’m not sure how to fix it now. :frowning_face:

I did try opening the network tab of the console, but I didn’t see anything that I could understand there when going through one such download loop. Nothing stuck out as an error or anything. Spoke too soon on that one. Checked again and I got:

Uncaught (in promise) {"req":{"jsonrpc":"2.0","id":716,"method":"call","params":["NsPHdkXtENoaotxVZWLqJorU52O7J0OI","modem","get_status",{}]},"error":{"message":"Internal error","code":-32603}}

Don’t know if the Spitz did an error when I wasn’t looking or it’s related to the download fail.

It looks like this is a Cellular Modem failure. Maybe it’s the unstable internet connection.
@lizh Can you check it further?

I’m about to head to bed, so in the off chance this information helps (since you mentioned the modem) I’ll leave it here:

During reboots, I’ve noticed that the Modem Name line is not always the same. Sometimes it says “RM520” and sometimes “RM520NGLAAR01A07M4G” and I haven’t observed enough to notice if there’s a pattern to when it says either. Also, despite having a sim in slot one, it always cycles the two sim slots on boot and initially claims there’s no sim and/or that it can’t connect via sim one before cycling back and finally registering on the network and connecting.

Is this the only interface ‘get_status’ that displays the error?

Does this have to happen?

I apologize if I misunderstand the question; I’m a new user and not familiar with the tech. By the best of my understanding, I think you’re asking if there are more errors. In which case, yes. I just turned on my laptop about ten minutes ago and logged into the Spitz interface. I already had it open and my laptop disables the network card when asleep so I’m not sure if the errors that popped up when I immediately opened the console are relevant. Here they are just in case:

Failed to load resource: net::ERR_INTERNET_DISCONNECTED

2app.1d907a46.js:16 Uncaught (in promise) Error: Network Error
    at t.exports (app.1d907a46.js:16)
    at XMLHttpRequest.d.onerror (app.1d907a46.js:49)

Uncaught (in promise) {"req":{"jsonrpc":"2.0","id":1176,"method":"call","params":["NsPHdkXtENoaotxVZWLqJorU52O7J0OI","modem","get_cells_info",{"bus":"0001:01:00.0"}]},"error":{"message":"Access denied","code":-32000}}

And the ones that have appeared after I confirmed my laptop was connected and I had logged into the admin interface for the Spitz AX:

Uncaught (in promise) {"req":{"jsonrpc":"2.0","id":1231,"method":"call","params":["T2FvXOB3DzLi6OugzpU9gvGE0RXXCe3D","modem","get_status",{}]},"error":{"message":"Internal error","code":-32603}}
Promise.then (async)
getModemStatus @ VM190:7
eval @ VM190:7
setTimeout (async)
getModemStatusTimeout @ VM190:7
getModemStatus @ VM190:7
eval @ VM190:7
setTimeout (async)
getModemStatusTimeout @ VM190:7
getModemStatus @ VM190:7
eval @ VM190:7

Uncaught (in promise) {"req":{"jsonrpc":"2.0","id":1362,"method":"call","params":["T2FvXOB3DzLi6OugzpU9gvGE0RXXCe3D","modem","get_status",{}]},"error":{"message":"Internal error","code":-32603}}

The second one has a massive list of information when I tap the down arrow on it, so I’ll spare you those details unless they’re relevant. It’s the same kind of “eval @ VM” type stuff. I saved it in a document in case you do want it, though, so feel free to ask.

I tried another download, and it seems to primarily affect mediafire (which is bad, because it’s one of the hosts I use to get files for work-from-home stuff) but can occasionally affect other downloads as well. When it reaches the end and cycles back to “starting…” I did not see any errors pop up in the console. On the third cycle, when it finished with “Failed - Network error” still nothing new in the console. Thinking it might be like last time and appear after the fact, I waited a few minutes. Unlike last time, nothing popped up, so it must have been coincidental timing.

Hi Forsythia:

Now there are two questions:
1,These API interfaces have error “32xxxx”;
If the above situation occurs, please send me the following log.

2, The network is very unstable, sometimes disconnecting?
Please execute the following command:



Thanks for responding.

1: According to the browser console, yes. I don’t really understand what I’m reading in the errors, but they are “code: -32000”. It’s been a long while since one showed up, and since I don’t really understand what all is in the log I’m afraid I can’t isolate only the relevant sections so it’s a bit long. But here’s the system log requested. Due to post size limits, I couldn’t copy/paste and did and export istead: logread.zip (34.1 KB)

2: The network is only unstable in specific situations: downloading files (not images or other media) and uploading. Even while it’s behaving this way, streaming and browsing and messaging are all unaffected. The behaviour I’ve noticed is that upload is wildly inconsistent, jumping up and down in a range from 2Mbps through 30Mbps second by second rather than holding a consistent speed. Downloads of files, especially from places such as mediafire and other cloud-hosting services, often get stuck in loops; when the file finishes, it restarts without saving, and does this twice before finally failing with a “network error” reported by the browser.

I had witnessed this behaviour on the APN that Auto Setup determined and fixed it by using the APN that the sim reports when put into a phone. Unfortunately, I now have the APN that had fixed it set, but post-upgrade it does not fix it and the behaviour persists. The APN Auto Setup suggests leads to lots of network issues, including sites timing out, download speeds of only 3Mbps, and streams breaking. I have the same experience using that APN in a phone, so I think it’s just not the right one for my plan.

I’ve not experienced any disconnects or other degradation in the connection now that I can actually get my devices to connect to the Spitz AX. Just weirdness with upload speeds and “network errors” during downloads - issues that were fixed pre-firmware-upgrade but have now returned.

Since the commands were preceded by the question, I’ve held off on them for now to ask: should I still run them or are they only intended for a router that’s disconnecting?