Spitz AX GL-X3000 cannot upgrade firmware

So… Spitz AX GL-X3000, showing firmware 4.0 - though I understand it displays that for certification reasons? I think it’s actually on 4.3.5. Trying to install 4.4.6, but running into some road blocks.

From the phone app, it all proceeds like it’s working fine, the progress indicator reaches 100% and… nothing. Just sits there. I tap ‘Close’ to back out, and I’m still back on 4.3.5.

When I try in the web dashboard, I get an immediate ‘Download failed, try again?’ message.

Any suggestions going forward?

You can try a manual upgrade

I believe I did that too at one point. Timed out just like the other (from the phone app).

Does manual upgrade display timeout?

Use a browser in a pc not your phone. And use LuCi to upload the firmware file .

So the firmware update function in the phone app - or the web app, for that matter - don’t work as advertised?

I tested the app a few times and it worked fine
Can you tell me the version number of your app?

2.4.9(188), shows a release date of 2024-04-07

Been having this problem for a while (months), so I don’t think it’s a recent regression.

Do you log in to the cloud platform through the APP and upgrade through the cloud platform connection

Never used the cloud aspect, no interest.

Can you record a video of the failed upgrade?
This may provide us with more useful information
Thank you very much!

Link for video:

It gets to the same point and just… nothing. I’ve let it sit 10-15 minutes and nothing.

Can you take a look at this position?

hello,Can you try to kill the app process, and then reconnect to the wifi, and then enter the app?

I can… but what exactly is the point?

The phone (Pixel 7 Pro) has been rebooted for system updates (that actually work) multiple times over the course of the time I’ve been trying to update the router. As recently as yesterday.

I don’t see killing the app and restarting it doing anything new/useful, compared to the complete OS reboots.

I remember having an issue like this when I first got my GL-X3000, it was resolved when I did a Uboot firmware update and since then have had no issues either on the regular website upgrade or the app upgrade pages.

Would suggest trying to routers own webpage updater instead of the app just this once and if that doesn’t work try Uboot. It may be an issue on the router side rather than the app which is why you restarting your phone doesn’t do anything.

Tried the router dashboard - the gl-inet skinned interface - and when I clicked to update it failed immediately, as described in the original post.

By ‘uboot’, you’re saying going into the ‘Advanced’ settings and using the base openwrt interface (luci)?

That’s actually worth a try as well, since that uses the base OpenWRT updater.

But no, Uboot is basically like putting an android phone in bootloader mode and flashing a new OS to it that way. It’s mainly intended for debricking a router with corrupted/broken firmware, since its in the router’s ROM and therefore ‘unbrickable’ (IE, a corrupted or incorrect rom file won’t stop it booting into Uboot).

But as mentioned, if it keeps refusing to update through multiple different methods, trying Uboot is worth a shot. In my experience once I used it once it has since been able to update through whatever other method I’ve tried.

Guide is here: